Why doesnt my keyboard on my laptop react after sleep

the laptop is from the asus rog zephyrus series and often the keyboard (but the touchpad) does not react, so that i have to use screen keyboard or reboot. i am new to linux and dont know what todo. ive read this article: Laptop keyboard unresponsive - #8 by Aravisian, it helped at first but after time the laptop was in sleep mode, the keyboard doesnt react anymore.

that "boot-repair" program from Do I need Microsoft firmware update when I use only Linux now? - #3 by Aravisian says at the beginning:

boot-repair-4ppa200-zorin1 [20221008_2010]

============================== Boot Info Summary ===============================

=> No boot loader is installed in the MBR of /dev/nvme0n1.

i dont know if this is essentiall for this topic.

1 Like

MBR is Master Boot Record. You would see MBR if you are using Legacy boot option.
Undoubtedly, on an NVMe drive, you are using EFI boot. The bootloader would be located int he EFI system partition.

You might change grub from what was tried in the other thread to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset"

Then be sure to run

sudo update-grub

There are quite a few Grub parameters that you can try...
Here is a list:

You do not need to try them all individually. You can pop them all in at once to see if any work:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1"

sudo update-grub

But in my opinion, it is better to reduce grub parameters to only what you need.
So I would try narrowing that list down to any that work all the time.

Okay, ill see itomorrow if everything works.
Thanks for your fast help.

well it didnt work :expressionless:

i have tried the multi option thing and straight up the keyboard didnt react after sleep anymore.

Please run

sudo nano /etc/default/grub

and change to


sudo update-grub

Then, please try

sudo apt install xserver-xorg-input-all

Then reboot and test.

i guess im stupid because i forgot to reboot

How are things currently functioning?

well the first solution doesnt seems to be working.

After some testing the solutions dont seem to be working.
And now it is stuck in boot. Switching ttys works but the cursor stays in the top left. tty1 just gives a blank screen. Reboot doesn't change anything.

To resolve this, it may be helpful if you can detail to the best of your memory what you tried - it may have led to your current predicament.

So uhm I've tried to game, but the power of te GPU was low so I've tried the app called some like greenwithenv to overclock. It didn't work at first, because I had to install proprietary Nvidia drivers. After reboot it had shown me details of my GPU and it let me change fan speed, but for overclocking it said it needs coolbits8 to be set. I've done that and next reboot it was stuck there.

How did you install GreenWithEnvy? Flatpak?

Yup with flatpak

Are you able to access the Recovery Menu rather than tty?
Tap the esc key vigorously after seeing the motherboard splash screen, then select Advanced Options for Zorin
From the grub menu, first enable networking. Then back out to the grub menu and arrow key down to Drop to Prompt.

flatpak uninstall com.leinardi.gwe

I am not sure if that above flatpak remove command is correct... I do not use flatpak.
Maybe it is su
How did you install your Nvidia Drivers directly?
To try to regain access to the desktop, you can try:

sudo nano /boot/grub/grub.cfg

Read Through looking for something similar to
linux /boot/vmlinuz-5.15.0-52-generic root=UUID=stuffsomethingandmorestuff ro quiet splash $vt_handoff
You may need to scroll a bit.
This is the part you want to pay attention to: quiet splash $vt_handoff Remove the $vt_handoff to make it just end with quiet splash

ctrl+x to exit, then the y key then the `enter key.

sudo update-grub

Once done, reboot and test...

I forgot to mention i had changed /etc/default/grub to 'quiet splash nomodeset" ' but now it's stuck in the loading screen after I've reset that change

Which Nvidia card are you using?

In regards to the keyboard; do you have any BIOS Power settings such as Wake on Keyboard or mouse enabled or disabled?

Which ASUS laptop are you using?

1 Like

Just to let you know, with my laptop (Asus K52N) I'm having the same issue with 2 services :triumph:. Looks like Zorin doesn't adapt well to the pc basic functions.

so i went to recovery mode, in root cmd line and removed that nvidia driver. My Computer booted up with the default gnome nvidida-driver and could set my driver in "Software & Update".
Also my graphics card is the Nvidia GeForce 3080, 16gb (Laptop-GPU).