Why wont my laptop detect after flashing zorion on my usb

Why wont my laptop detect after flashing zorion on my usb?

1 Like

https://www.makeuseof.com/tag/fix-usb-device-port-linux/#:~:text=If%20USB%20is%20not%20detected,with%20the%20other%20USB%20port.

You can check your BIOS / EFI settings or reset them to default.
Or try using a different USB port.
It may be the USB stick itself that is not working right - you could try using a different USB stick. Try using a different burner, too. If using Windows OS to burn the Bootable USB Medium, try using Rufus.
I recommend Ventoy, Unetbootin or Popsicle on Linux OS's.

so speaking theoretically the usb i just bought is now completely useless... according to the forum post

It is possible that the USB stick is malfunctioning and therefor worth checking.
Have you checked your BIOS / EFI settings?
Did you use Balena Etcher?

2 Likes

Correct ..... I have read here on the forum many times about people having their USB sticks bricked because of someone using Balena Etcher ..... I know the Zorin instruction page says to use it but with all the problems people have I wonder why they don't change that ??????

Not just here...
This has been reported many times to the Balena Etcher Developers.
However... in spite of the numerous reports that are proportionately high for Balena Etcher, the Balena Devs claim that there is no problem.

3 Likes

It's a real shame because Balena Etcher is really a lot simpler than Rufus ... which is what I now use .... although I have used Balena Etcher when I first started Zorin and never had a problem I only used it twice .... I was lucky .....

1 Like

Tried Popsicle, yet?

1 Like

BalenaEtcher caused me a host of install issues with several different Linux distributions. Bad burns, corruption, etc. Finally went to RUFUS and got good, clean installs.

I did test the two different Sandisk USB sticks I was using and they were good. BalenaEtcher was the problem.

1 Like

No cause I haven't needed to made a bootable device lately but if I do I'll sure look into it ..... thanks

I just installed Popsicle in case I ever need it but haven't tried it out yet .... I'll check out some videos on the Tubie to see what it looks like ....

I use popcicle or ventoy depending on what I am doing

for the 'bricked' usb, from belena i have had it happen twice both times i have fixed it with a dd command provided by the belena devs, which leads me to believe the issue is the corruption of mft/gpt resulting in a seemingly dead stick

2 Likes

The command I used was

sudo umount /dev/sdb
su
dd if=/dev/zero of=/dev/sdb bs=512

replace sdb with what ever your USB stick is. sda sdc ect

2 Likes