Wi-Fi 6 AX200 not working

Hi my internet isn’t working but is being detected in console i have not got windows install, fast boot not on and secure boot not on

Welcome! :smile:

Might be a bit repetitive, if you've already done so: What does sudo lshw -C network show? Also, what does sudo dmesg | grep -i wifi and if that doesn't show anything: sudo dmesg | grep -i network.

And - what machine are you using, make / model? I'm willing to bet it's a driver issue.. I've seen a lot of the AX2xx series so far that don't quite work OOB (out of the box) but, with mitigation of course.

Thanks for the fast reply
The version is Zorin OS 16.3
Make - pc specialist

No worries!

That looks good though.. Are you able to see any WiFi networks from neighbors or anyone else? In Settings, WiFi - is airplane mode enabled or maybe the WiFi is turned off?

What do you see when you issue rfkill list? :thinking: Should list your wireless devices, and if they're in a soft or hard block.

I had to search for that PC you're using - have not heard of those, ever lol Maybe just a UK thing; I'm over in the colonies :laughing: They look good though!!

I cannot see anyones wifi. when I do rfkill list nothing shows up and when I go into the wifi settings it shows no wi-if adapter found I have been looking around and I did iwconfig
Which gives out a output of:

Lo no wireless extensions
Enp6s0 no wireless extensions

Weird... still - usually the lshw command will show if the device is 'unclaimed' which would point to a driver issue......

But, I found this:

There is a driver for download and a few other ways to check if driver issues are what's going on, and the install - might save on gapped time between posting and trying what could be..

There could also be a fix with updating - you could use your phone as a USB tether or plugging into Ethernet and running sudo apt update && sudo apt upgrade through terminal. Could also be updated through the Software Updater GUI - both do the same, one's just terminal, heh.

Problem I don’t have access to a Ethernet so how can I use my phone ?

You attach USB cable that you would normally connect to charging plug for charging and connect USB that would go to plug to PC. When you do this you have to pull down the screen at the top of your phone and you should see USB options - select Tethering. You may need to pay for additional data package - I had to pay for unlimited data to do this when I had a major issue with my ISP during lockdown when working from home. This guide should help you:

I know it says for laptop (I prefer to use the term notebook) but the procedure is still the same for USB tethering.

1 Like

If you're using Android - plug in your USB cable, go to Settings, then (depending on your Android version) where WiFi, BT, and SIM management options are - go to 'Other wireless connection', and you should see 'USB tether'. Might be grayed out if the USB isn't plugged in, or if the cable is charge-only. The USB tether can also be found when searching in Settings as well - if it cannot be found.

Apple stuff... I'm not sure, I've not had any iStuff to know - Android since day 1 haha this article has how to USB tether from iDevices.

If Bluetooth is available and working, you may also be able to tether through USB - but since most newer setups have WiFi and Bluetooth on the same chip, that might not be available..

I updated the kernel but nothing happens im trying to find a driver but i cant find one on the intel website i can only find the Intel® Wi-Fi 6 AX210 160MHz 5.10+ no newer ones i have installed the newest one and no luck

The guide that I posted has a driver that you can download and install, I can't confirm if that will be working or not though; sixth post. <-- Maybe not the driver provided by Intel --

Mentions adding the backports ppa and installing the driver, maybe a different one than offered by Intel - would make sense. But: drivers - Intel Wi-fi 6 AX200 adapter not found on Ubuntu 20.04 - Ask Ubuntu - about midways through, small post, three lines of terminal input. The newer kernels may or may not include them, anymore - was reading that 5.8 kernels and newer shouldn't be a problem but, that's been a while now.. There are also some others that fixed through other means.

I just wanted to say thanks guys for helping me but it just ain’t working everything I do just don’t even work :sob::rofl:idk what to do

No worries; I don't like giving up though! :wink:

When you installed the most recent driver, did you issue a modprobe command to initialize the driver? May have been something like: sudo modprobe -v iwlwifi - or something different. There should have been a modprobe command maybe near the bottom of the install guide from your last attempt. Can you post a link to the driver that you most recently used?

it is Intel® Wi-Fi 6 AX210 160MHz 5.10+ iwlwifi-ty-59.601f3a66.0.tgz

And I'm taking it that you copied the .ucode to the /lib/firmware directory? There may be another directory inside ../firmware that the driver needs to go to..

What do you have in /lib/firmware?

And.. you may need to remove the other firmware files *.ucode that do not relate to the one you're trying to use - in this case, the *59.ucode file. modinfo iwlwifi will show you where the device is trying to pull a driver from. Which will also tell you where to place the .ucode file :grin:

I know - it's windy (lengthy lol) but, little bit of T-shooting helps pin it down. And I'm pretty sure you should be using a modprobe command to initialize that driver with sudo modprobe iwlwifi.

Actually, try that now before anything else since you've got something in there for drivers if you haven't ran that before: sudo modprobe iwlwifi, then reboot. If it does 'nothing' and just drops to the next line with your cursor blinking and no output, that should have loaded the .ucode file - then reboot to see if that took effect..

Wait I just put the tar.gz in the folder do I need to put the Unicode files in there where can I get them

So, tar.gz is Linux compressed folders - you'll have to extract that .tar.gz - I would also remove that from the /lib/firmware directory as well, just to keep things neat... Just right click it and 'extract here' for a directory (folder) with the files inside, then place the .ucode in /lib/firmware. You'll need root permissions since you're copying to system directories. Easiest way is through terminal, but need to be in that directory where it was extracted to move them - usually you can right click empty space in the directory you're in and have a 'Open in Terminal' option - then it will have a terminal with your location in that directory. Now, use sudo cp *.ucode /lib/firmware, enter your password, then sudo modprobe iwlwifi and reboot.. :crossed_fingers:

i have rebooted internet is not on

Okay.. run sudo modprobe -r iwlwifi, remove any iwlwifi--.ucode files in /lib/firmware, reboot, replace the iwlwifi--.*59.ucode, rerun sudo modprobe -v iwlwifi, then reboot again.. (edited, formatting kinda messed with the text..)

There may be a .ucode file that's conflicting with what it's trying to load for kernel use, if more than one are in the same place..

i ran the first command witch did nothing then deleted them all there was like a 100 haha then restarted i tried doing this command sudo modprobe -v iwlwifi did nothing