Wi-fi does not work despite Bluetooth being available

I got a PC with a graphics board and installed Zorin OS. But only the built-in wi-fi does not help despite Bluetooth being available. I connected an old wi-fi dongle (it is slow!) and tried to install the drivers but no effect. It may be cause by Nvidia drivers. Is there anything I can do to solve the problem?

$ inxi -b
  Host: hgyamada-PM-B560 Kernel: 6.5.0-21-generic x86_64 bits: 64
    Desktop: GNOME 43.9 Distro: Zorin OS 17
  Type: Desktop System: Mouse product: PM-B560 v: N/A
    serial: <superuser required>
  Mobo: Mouse model: B560M serial: <superuser required>
    UEFI: American Megatrends LLC. v: M.010 date: 10/28/2021
  Info: 6-core 11th Gen Intel Core i5-11400F [MT MCP] speed (MHz): avg: 2557
    min/max: 800/4400
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate] driver: nvidia
    v: 535.154.05
  Display: x11 server: X.Org v: driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia
    resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce RTX 3060/PCIe/SSE2
    v: 4.6.0 NVIDIA 535.154.05
  Device-1: Intel Ethernet I219-V driver: e1000e
  Device-2: Intel Wi-Fi 6 AX200 driver: N/A
  Device-3: BUFFALO (formerly Mel ) WLI-UC-GN Wireless LAN Adapter [Ralink
    type: USB driver: rt2800usb
  Local Storage: total: 505.79 GiB used: 19.11 GiB (3.8%)
  Processes: 327 Uptime: 26m Memory: 15.47 GiB used: 2.89 GiB (18.7%)
  Shell: Bash inxi: 3.3.13
$ sudo lshw -C network       
  *-network UNCLAIMED       
       詳細: Network controller
       製品: Wi-Fi 6 AX200
       ベンダー: Intel Corporation
       物理ID: 0
       バス情報: pci@0000:04:00.0
       バージョン: 1a
       幅: 64 bits
       クロック: 33MHz
       性能: pm msi pciexpress msix cap_list
       設定: latency=0
       リソース: メモリー:a3200000-a3203fff
       詳細: イーサネット interface
       製品: Ethernet Connection (14) I219-V
       ベンダー: Intel Corporation
       物理ID: 1f.6
       バス情報: pci@0000:00:1f.6
       論理名: enp0s31f6
       バージョン: 11
       シリアル: a8:a1:59:7c:58:2d
       容量: 1Gbit/s
       幅: 32 bits
       クロック: 33MHz
       性能: pm msi bus_master cap_list __________________ physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       設定: autonegotiation=on broadcast=yes driver=e1000e driverversion=6.5.0-21-generic firmware=0.4-4 latency=0 link=no multicast=yes port=twisted pair
       リソース: irq:127 メモリー:a3400000-a341ffff
       詳細: 無線インターフェース
       物理ID: 5
       バス情報: usb@1:5
       論理名: wlx0024a57ed14c
       シリアル: 00:24:a5:7e:d1:4c
       性能: __________________ physical wireless
       設定: broadcast=yes driver=rt2800usb driverversion=6.5.0-21-generic firmware=0.36 ip= link=yes multicast=yes wireless=IEEE 802.11

Could be a Kernel issue try with an older kernel.

And keep the secure boot disabled.

1 Like

The Wifi 6 AX series have been consistently troublesome. Looking around the forum, you will find many posts on Wifi6 AX200, AX210...
There are a couple of suggestions here that may be helpful:

1 Like

I eventually gave up. Intel's wi-fi drivers are notorious, and since my machine is a desktop, it makes little sense to have wi-fi built in. Thanks for advices.

I moved the solution to your post since my suggestion did not provide any solution that worked for you and your solution was to stop gnashing your teeth over the problem and use a Wifi Dongle.

The solution can be changed in future to a newly presented one should this topic be revisited.

1 Like

I removed the useless wi-fi card and sold it for 1,500 Yen. This is enough money to buy a new wi-fi dongle. :upside_down_face:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.