Wi-Fi fails after update

Installed Zorin Os 16 on a Dell Latitude E6430. Wi-Fi works but after update and restart "Connection Failed".

This is the third attempt with the same outcome. Wi-Fi is a Broadcom BCM 43228 [14e4:4359]

First - connect the computer using phone hotspot or ethernet cable.

Let's see if removing any existing drivers:

sudo apt purge broadcom-sta-dkms broadcom-sta-source broadcom-sta-common bcmwl-kernel-source

Then installing direct:

sudo apt update && sudo apt upgrade

sudo apt install -y bcmwl-kernel-source

1 Like

Thnx Aravisian. Reinstalled using UEFI and tried without NVIDIA and after restarting the Wi-Fi worked.

I don't know but decided not to mess with happy and just leave it alone. May investigate later when I have a little more time.

I have seen Nvidia drivers mess with networking before. Could be related?

The only way I can see Nvidia affecting WiFi is if the GPU is pulling so much power that it kicks in the Powersave on wifi.
Disabling PowerSave is done by

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Change the value from 3 to 2:

wifi.powersave = 2

I have seen this on older versions of Ubuntu and the current Elementary OS. I have no idea what the connection is but it is possible. (Only happens when using non-kernel drivers)

If you google about nvidia breaking wifi/networking etc. on ubuntu you will find a few examples of it.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.