WiFi - 5 GHz network has worked fine until new updates

Hi everybody,

I've been using and loving Zorin OS 16 for some months, and I finally feel that is my definitive distro.

But since some days ago, I'm unable to keep a stable connection to 5 GHz WiFi. I can connect, but after some seconds, a pop-up appears asking me again the WiFi password. 2 GHz WiFi works corretly.

The connection to 5 GHz channels worked flawlessly since first day, even I've tried to boot from a flash drive with the bootable Zorin OS image, and works perfectly fine.

I've tried to disable advanced configurations from AP devices (our network uses AC-Lite and AC-LR Unifi AP's), but to no avail. Every other laptop or smartphones at home works without any problem with 5 GHz WiFi.

I can't think of anything else but a change with the latest updates of the OS, but not sure how to track it or solve it.

This is the exit of inxi -Faz:

System:    Kernel: 5.10.0-1051-oem x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10.0-1051-oem root=/dev/mapper/vgzorin-root ro quiet splash vt.handoff=7 
           Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 3.38.2.1 Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal 
Machine:   Type: Laptop System: HP product: HP EliteBook 840 G7 Notebook PC v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: HP model: 8723 v: KBC Version 06.37.00 serial: <filter> UEFI: HP v: S70 Ver. 01.03.02 date: 11/04/2020 
Battery:   ID-1: BAT0 charge: 46.5 Wh condition: 46.5/53.2 Wh (87%) volts: 12.8/11.6 model: Hewlett-Packard Primary 
           type: Li-ion serial: <filter> status: Full cycles: 45 
CPU:       Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: C (12) microcode: EA L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 33599 
           Speed: 800 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds mitigation: TSX disabled 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9b41 
           Display: x11 server: X.Org 1.20.11 driver: i915 compositor: gnome-shell tty: N/A 
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.0.3 direct render: Yes 
Audio:     Device-1: Intel vendor: Hewlett-Packard driver: sof-audio-pci bus ID: 00:1f.3 chip ID: 8086:02c8 
           Sound Server: ALSA v: k5.10.0-1051-oem 
Network:   Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:02f0 
           IF: wlp0s20f3 state: up mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 33.92 GiB (14.2%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 model: KBG40ZNV256G KIOXIA size: 238.47 GiB block size: physical: 512 B logical: 512 B 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: HP00AE00 scheme: GPT 
Partition: ID-1: / raw size: 237.00 GiB size: 232.28 GiB (98.01%) used: 33.92 GiB (14.6%) fs: ext4 dev: /dev/dm-0 
           ID-2: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 45.0 C mobo: 25.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 299 Uptime: 1h 05m Memory: 15.42 GiB used: 2.56 GiB (16.6%) Init: systemd v: 245 runlevel: 5 Compilers: 
           gcc: 9.3.0 alt: 9 Shell: bash v: 5.0.17 running in: gnome-terminal inxi: 3.0.38

The kernel is: 5.10.0-1051-oem

Thanks a lot in advance!

George

Can you also please include the terminal output for

sudo lshw -c network

1 Like

Hi Aravisian!

Thanks for the prompt answer!

  *-network                 
       description: Wireless interface
       product: Wireless-AC 9462
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       logical name: wlp0s20f3
       version: 00
       serial: fc:b3:bc:97:59:96
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.10.0-1051-oem firmware=59.601f3a66.0 QuZ-a0-hr-b0-59.u ip=192.168.1.233 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:16 memory:e0110000-e0113fff

Thanks!

Can I ask why you are currently on the 5.10 oem kernel?
Is that to provide any drivers missing in the current Zorin 5.11.0-40 kernel?

2 Likes

Well, I didn't messed yet with kernels, just worked through the regular updates. I'm not aware of the latest kernel available. I must check how to jump to 5.11.0-40 kernel.

You can try

sudo apt update && sudo apt full-upgrade

If that does not work, then you can install them manually:

sudo apt install linux-headers-5.11.0-40-generic linux-modules-5.11.0-40-generic linux-modules-extra-5.11.0-40-generic linux-image-5.11.0-40-generic

If modules-extra gives you any trouble, just remove that package from the command above.

2 Likes

Thats what i wanted to ask as wel, because zorin 16 comes with 5.11.27 kernel in the launch iso / r1

1 Like

Thanks for the steps.

I have updated to 5.11.0-40 but the problem is still there: connection doesn't last more than few seconds and the pop-up appears again asking for the password.

Did you reboot into the kernel?

You might try the suggestions made here:

1 Like

It could be your ISP and issues with their signal via WiFi...if there is a large use in household or if your access is to far from router/ our connecting via a public network.

2 Likes

Perhaps a hard reboot/restart?

2 Likes

Yes, I don't know why I was running 5.10 kernel, now I have booted from the flash drive into 5.11.0-27-generic, the exact same flash drive I used to install some months ago Zorin OS. Why did I ended with a downgraded kernel?

Yes of course, I have booted into 5.11.0-40.

I will try the steps you have suggested to me, thanks! I will inform with the result.

1 Like

Well, now I have booted again from flash drive with kernel 5.11.0-27-generic, and the connection to 5 GHz WiFi is quite stable. But even so, after a while from being connected, it asks again for the password from time to time. I really don't get it. It has been working for months with 5 GHz WiFi without any isue, at all!

I will try to follow @Aravisian advices and see if I can solve it.

Thanks a lot to everybody for your tips!

Can you check:

sudo apt install --reinstall policykit-1 policykit-1-gnome

1 Like

Wait a minute, this is the output of dmesg:

[ 6706.497299] wlp0s20f3: authenticate with fa:92:bf:c5:b9:7e
[ 6706.500595] wlp0s20f3: send auth to fa:92:bf:c5:b9:7e (try 1/3)
[ 6706.527772] wlp0s20f3: authenticated
[ 6706.531303] wlp0s20f3: associate with fa:92:bf:c5:b9:7e (try 1/3)
[ 6706.536962] wlp0s20f3: RX AssocResp from fa:92:bf:c5:b9:7e (capab=0x1511 status=0 aid=1)
[ 6706.543434] wlp0s20f3: associated
[ 6758.917035] wlp0s20f3: disconnect from AP fa:92:bf:c5:b9:7e for new auth to fa:92:bf:25:4f:42
[ 6758.924162] wlp0s20f3: authenticate with fa:92:bf:25:4f:42
[ 6758.930915] wlp0s20f3: send auth to fa:92:bf:25:4f:42 (try 1/3)
[ 6758.959314] wlp0s20f3: authenticated
[ 6758.962906] wlp0s20f3: associate with fa:92:bf:25:4f:42 (try 1/3)
[ 6758.969028] wlp0s20f3: RX ReassocResp from fa:92:bf:25:4f:42 (capab=0x1511 status=0 aid=1)
[ 6758.974204] wlp0s20f3: associated
[ 6763.018734] wlp0s20f3: deauthenticated from fa:92:bf:25:4f:42 (Reason: 2=PREV_AUTH_NOT_VALID)
[ 6768.669655] wlp0s20f3: authenticate with fa:92:bf:c5:b9:7e
[ 6768.673558] wlp0s20f3: send auth to fa:92:bf:c5:b9:7e (try 1/3)
[ 6768.701972] wlp0s20f3: authenticated
[ 6768.702583] wlp0s20f3: associate with fa:92:bf:c5:b9:7e (try 1/3)
[ 6768.709794] wlp0s20f3: RX AssocResp from fa:92:bf:c5:b9:7e (capab=0x1511 status=0 aid=1)
[ 6768.717468] wlp0s20f3: associated

As you can see, some seconds/minutes sometimes, pass between connection and disconnection, the reason: PREV_AUTH_NOT_VALID

I will check what this means.

1 Like

I have tried it but...

zorin@zorin:~$ sudo apt install --reinstall policykit-1 policykit-1-gnome
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package policykit-1-gnome is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'policykit-1-gnome' has no installation candidate

I see.
Hmmm... It is in the repository and I just checked on mine and it installs/reinstalls without trouble.

Can you open Software & Updates and look to Download From. Ensure that is set to Main Server.
Once you have done that. open terminal and run

sudo apt update && sudo apt install --reinstall policykit-1 policykit-1-gnome

sudo apt full-upgrade

Also, please link to where you downloaded Zorin OS from...

1 Like

I think I have some clues: the connection is swapping between two AP's, but don't know why is asking me for password when roaming to another AP. I forgot to state that I have configured a mesh WiFi with three AP's. Every other devices, even this laptop till now, are working as it should, roaming between AP's without problems and of course not needing to reenter passwords.

I will boot again from HDD and try your suggestions, thanks!

2 Likes

I downloaded Zorin OS from this site.