WiFi 6 AX101 and touchpad don't work

Didn't catch that first read through - did see a suggested backport-iwlwifi DKMS driver and Zorin does have that package in apt!

Second the USB tethering!

I saw that as well. I remain pessimistic, perhaps for good reasons. I would rather be wrong in my suspicions than hopeful but disappointed.

1 Like

I've never shared internet via usb with my phone. I will try and report back. Thank you guys for trying to help.

1 Like

The weirdest thing happened. When I logged in the Touchpad worked perfectly, then I proceeded to upgrade the kernel and installed 6.4. After rebooting the machine now the wifi works perfectly and the touchpad doesn't.

1 Like

Does it register the device; can you make changes in Settings?

Now, that's an odd result..

1 Like

I am getting some error messages during boot. is there a way to read those once I'm in Zorin?

Maybe, sudo cat /var/log/boot.log?

That will show the boot process as you're splash is displaying.

1 Like

I'm not seeing anything. I think I shouldn't have updated to such a new Kernel because now I have no audio either. I didn't tested the audio before updating, though. I will try going back to an older kernel.

1 Like

What did you update to? I've seen some talks about getting a 6.5 kernel installed and it working - 16.3 is supposed to have kernel 6.2 but Lite still has 5.15 - #31 by Aravisian

Didn't sound like that was the fix though..

I should have prefaced that: if you didn't do any updates or change any configs with the kernel that didn't work, you should be able to use the advanced startup option in GRUB and choose the previous version.

Also - this came with Windows installed, right? What steps did you take before installing Zorin? I had one heck of a hootin time with the little Gateway and Mint - didn't do this and that before booting and installing. First time I've ever experienced it myself. I had to end up reinstalling Win, disabling all the features outlined in the 'before you install' section, fiddle with BIOS options, then it worked. For some issues, I've found that just booting the Win installer, clicking some options but not changing any permanent settings, shutting down (not rebooting), then proceeding with booting Linux - and all is well. Weird - just, weird..

Did wifi work with the Zorin live disk; or the other live disk?

No, wifi didn't work. I had to upgrade to the 6.5 kernel. I've found out since then that 6.4 has wifi as well. as for the touchpad problem I discovered that disabling d3cold from the BIOS' ACPI settings solved the problem. Now all that's left is figuring out why no matter what I do I have no sound. Output devices keep showing "Dummy Output"

Hey, sounds good! The.. wifi, not the sound..

Sound - yeah had some 'dummy output' myself.. on a dual-boot. Had to boot into Windows, shutdown, then power on, and boot into Zorin - sound active! I have Intel "Smart Sound Technology" (I put quotes cause I think it's dumb..).

So, try this - boot into a Windows installer (USB or disc), click around a bit, maybe look through some options but do not change anything permanent!! I.e., no partition changes, no installing, etc.. and then shutdown.

I've revived my sound this way after installing, not Zorin, but after installing Linux - but also not shutting down, just rebooting. Windows takes over the sound bus on new systems, especially during a warm-boot - fun, right? :joy: I try to keep a light heart on some of this stuff - just because I know how frustrating it can be..

The days of just nuking a HDD/SSD and installing Linux to just work - are done.. Secure boot, Fast startup, new Windows stuff taking over hardware during warm-boots - all stuff that I've had to learn myself through the last few years. The sound problem drove me insane.. the installer played, at full volume, the Zorin start sound - pleasant.. but gots the ringin in me ears now :rofl: jk.. light hearted thing agian..

Give that a shot - see if that helps, if it doesn't - we're here for anything you need! I'm on east coast time (US here), so might be a bit of a delay - but tons of good guys and gals here! :smile:

I will try that, but I have fast boot disabled on windows. Even the pagefile is disabled. I don't remember having checked if there's sound in the zorin live. But yesterday I installed Fedora 38 and it had sound. I don't like Fedora 38 so I gave zorin a chance thinking maybe since I had fixed the touchpad and wifi problem now I could do something about the sound. I am downloading w10 now to run it and see if the sound comes back to Zorin.

Thanks for everything.

1 Like

Absolutely! :smile:

Suggest you start a new thread for this sound problem.
You could also do a forum search for "Dummy Output", you will see some threads on that subject.

1 Like

After googling and doing everything I could, installing like three ubuntu based distros I decided to move to arcolinux with the latest kernel and now the audio works. I don't know why it doesn't in ubuntu/debian based distros but I won't waste more time looking for a solution.

1 Like

Oh, you could install a newer kernel with Zorin - have seen some install up to 6.5 so far. 16.3 is supposed to have kernel 6.2 but Lite still has 5.15 - #18 by Aravisian

Out of the distros you tried, did you try any MATE flavors?? Have had better HW support in MATE distros vs others.

All Kernels have no sound, yet all arch installs that I've tried have sound. As for Mate, I just like gnome. Well specifically I like the design consistency in the program, but I don't like that toolbar or even the full screen app launcher. But I like that all apps have consistent four rounded corners. I care a lot about design and that is why I like Zorin, but if audio is going to be a problem and no matter what solution I try fails I have to look somewhere else.

Also I have found that the GNOME compositor is the best compositor I've tried, if xfce used it I could see myself using xfce with gtk4 applications.

1 Like

I am happy to report that I fixed the dummy audio problem but it was on arch. I am leaving what I did here in case anybody else has this problem:

I did a bunch of things but what fixed it was installing
sof-firmware and alsa-ucm-conf. After that I rebooted and it all worked. The only problem was the power saving mode was turning the audio on and off and producing an awful scratching sound so I had to install wireplumber and copy /usr/share/wireplumber/main.lua.d/50-alsa-config.lua to /etc/wireplumber/main.lua.d/50-alsa-config.lua

then do
sudo nano /etc/wireplumber/main.lua.d/50-alsa-config.lua

and edit the line
--["session.suspend-timeout-seconds"] = 5
["session.suspend-timeout-seconds"] = 0

then systemctl --user restart wireplumber and that's it


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.