WiFi 6 AX101 and touchpad don't work

I will try that, but I have fast boot disabled on windows. Even the pagefile is disabled. I don't remember having checked if there's sound in the zorin live. But yesterday I installed Fedora 38 and it had sound. I don't like Fedora 38 so I gave zorin a chance thinking maybe since I had fixed the touchpad and wifi problem now I could do something about the sound. I am downloading w10 now to run it and see if the sound comes back to Zorin.

Thanks for everything.

1 Like

Absolutely! :smile:

Suggest you start a new thread for this sound problem.
You could also do a forum search for "Dummy Output", you will see some threads on that subject.

1 Like

After googling and doing everything I could, installing like three ubuntu based distros I decided to move to arcolinux with the latest kernel and now the audio works. I don't know why it doesn't in ubuntu/debian based distros but I won't waste more time looking for a solution.

1 Like

Oh, you could install a newer kernel with Zorin - have seen some install up to 6.5 so far. 16.3 is supposed to have kernel 6.2 but Lite still has 5.15 - #18 by Aravisian

Out of the distros you tried, did you try any MATE flavors?? Have had better HW support in MATE distros vs others.

All Kernels have no sound, yet all arch installs that I've tried have sound. As for Mate, I just like gnome. Well specifically I like the design consistency in the program, but I don't like that toolbar or even the full screen app launcher. But I like that all apps have consistent four rounded corners. I care a lot about design and that is why I like Zorin, but if audio is going to be a problem and no matter what solution I try fails I have to look somewhere else.

Also I have found that the GNOME compositor is the best compositor I've tried, if xfce used it I could see myself using xfce with gtk4 applications.

1 Like

I am happy to report that I fixed the dummy audio problem but it was on arch. I am leaving what I did here in case anybody else has this problem:

I did a bunch of things but what fixed it was installing
sof-firmware and alsa-ucm-conf. After that I rebooted and it all worked. The only problem was the power saving mode was turning the audio on and off and producing an awful scratching sound so I had to install wireplumber and copy /usr/share/wireplumber/main.lua.d/50-alsa-config.lua to /etc/wireplumber/main.lua.d/50-alsa-config.lua

then do
sudo nano /etc/wireplumber/main.lua.d/50-alsa-config.lua

and edit the line
--["session.suspend-timeout-seconds"] = 5
into
["session.suspend-timeout-seconds"] = 0

then systemctl --user restart wireplumber and that's it

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.