WiFi activation failed to connect / ethernet does not work

Hi I am new to Zorin but seem to have a very strange problem with my internet.

I have a WiFi card which used to connect to my router fine. Then one day it connected and has signal but "activation failed to connect" message appeared an a question mark appeared in the logo. I have tried all the trouble shooting I can find but nothing seems to work, but strangely it is able to connect to my phone as a wireless hotspot with no problems.

The other issues, which is less important but more confusing than anything is that the ethernet is not recognised at all, I have never been able to connect to it but know it works because I have connected it to other devices.

Please give the output of lshw -c network from the terminal (ctrl+alt+t).

rosa@rosa-Build:~$ lshw -c network
WARNING: you should run this program as super-user.
*-network
description: Wireless interface
product: Intel Corporation
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 1a
serial: 60:f2:62:51:0e:05
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.4.0-70-generic firmware=48.4fa0041f.0 ip=192.168.0.24 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:29 memory:f6600000-f6603fff
*-network UNCLAIMED
description: Ethernet controller
product: Realtek Semiconductor Co., Ltd.
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:04:00.0
version: 04
width: 64 bits
clock: 33MHz
capabilities: cap_list
configuration: latency=0
resources: ioport:f000(size=256) memory:f6500000-f650ffff memory:f6510000-f6513fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

For "activation failed to connect": The OP on this thread has a VPN related problem but there are several non-VPN-related solutions offered. Can you try them to see if that fixes the problem?

For your "Unclaimed" controller: I suspect it is a kernel issue. You could consider trying the Zorin 16 beta and seeing if that fixes it.

1 Like

Mine is a non-VPN and I tried those but it did not work.

I think it might be a driver issue not the kernel because it is the same issue on Zorin 16 beta.

Looking over your specs above, it should work. It may just need modprobe.
But just in case, can you first ensure that Secure Boot is disabled in EFI settings? This often causes this problem as you describe.

Secure boot is turned off. How do I add a modprobe?

Rosa, I am sorry. I've been all over the place this past week. I did not realize this thread was awaiting response. 'Network Unclaimed' means that the system is not associating the Realtek driver with the hardware. Modprobe is a utility to add or remove modules. As Zorin is a System.d OS, it uses Modules with the Kernel to communicate with the hardware. Modules are basically Drivers.
In terminal, please run:

sudo modprobe r8168

to tell modprobe to add the Realtek Module. It is possible that you may need to download or install Realtek drivers. But you should have them from your OS installation.

Not a problem, I know how things can get and my original message wasn't clear I still needed help. Below is what I get when I try

$ sudo modprobe r8168
[sudo] password for rosa:
modprobe: FATAL: Module r8168 not found in directory /lib/modules/5.4.0-72-generic

For some, it still turns wifi on in spite of the error warning. Any luck there?
If still no wifi, you may need to install the modules or driver. Installing the realtek driver gets trickier and it often requires reinstalling it tediously after each update. I would prefer to avoid that route- and the Linux Kernel should contain the proper modules. Given your output above, you have the 5.4 kernel. Let's try reinstalling it. Copy each into terminal in succession without logging out or rebooting until you have completed the terminal session:

sudo apt remove linux-image-5.4.0-70-generic

sudo apt autoremove

sudo apt install linux-image-5.4.0-70-generic

sudo apt install linux-modules-extra-5.4.0-70-generic

Once complete, reboot and test.

It looks like the wifi has connected but the speed is extremely slow. and still nothing from the ethernet.

Can you please re-run lshw -c network and post the results?

WARNING: you should run this program as super-user.
*-network
description: Wireless interface
product: Intel Corporation
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 1a
serial: 60:f2:62:51:0e:05
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.4.0-72-generic firmware=48.4fa0041f.0 ip=192.168.0.24 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:29 memory:f6600000-f6603fff
*-network UNCLAIMED
description: Ethernet controller
product: Realtek Semiconductor Co., Ltd.
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:04:00.0
version: 04
width: 64 bits
clock: 33MHz
capabilities: cap_list
configuration: latency=0
resources: ioport:f000(size=256) memory:f6500000-f650ffff memory:f6510000-f6513fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Can you run in terminal:

sudo apt purge r8168-dkms

Reboot and test.

Otherwise can you read here:
https://itectec.com/ubuntu/ubuntu-how-to-install-wi-fi-driver-for-realtek-rtl8821ce-on-ubuntu-18-04-duplicate/
Scroll down and follow the step by step solution offered there and let's see if that works.

So I first tired your solution and had this output

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package r8168-dkms

Again it still connnects but is very slow and sometimes the wifi logo has a ? in it.

the other solution from the link does not work, I tried the first command and it comes you with "abort"