Wifi adapter not detecting/functioning after fresh minimal install

Hi I did a clean install of Zorin 17.1 minimal. I've completed all updates etc but it seems like my wifi adapter is not functioning. Likely just drivers. Wifi adapter is an Intel® Wireless-AC 8265. PC is a Lenovo ThinkCentre M910q
any advice on trying to get the adapter working would be appreciated.
I've tried : sudo apt install backport-iwlwifi-dkms and rebooted
tried lshw -c network and it comes back with unable to read network - open {2: No such file or directory)

Did you have, or do you still have Windows installed as dual-boot?
Did you disable Fast Start in Windows? See this: Intel Wireless 8265 does not work in any version of Linux but works with Windows - Ask Ubuntu
Windows Fast Start behaves a bit like hybernation when you hit shutdown. There have been reports on the forum of Windows hanging onto hardware in such circumstances.

Hi I am not running dual boot. I haven't check if fast start is on in the bios I will check tonight when I am home and confirm. I will have a look at the link you attached and give that a try as well

Fast Start setting is in Windows, Control Panel>Power Options>What the Start Button Does.

I realized that shortly after I responded. I am not dual booting on that pc at all though it's only running Zorin

I am having the same experience with my ASUS TP410UAR laptop. I just erased Windows 11 to install Zorin. I will also relook in the BIOS if there is a Fast Start option.


  1. I disabled Fast Boot from the BIOS - no change
  2. I tethered my laptop with my cell phone and downloaded the latest update - no change.
  3. Laptop is less than 30 feets from my WiFi router.

Ready for some advice/suggestion

Second Update:

Finally got it working using a tip from another user responding to this WiFi adapter error. In short, the rather unusual solution was:

  1. shutdown laptop
  2. disconnect power cord
  3. hold the power button down for 30 sec
  4. reconnect power cord
  5. restart laptop

Not sure why this trick actually resolved my problem. Now back to learning Linux :slight_smile: