Wifi adaptor not found

I recently installed Zorin os on my laptop but now the wifi is not working there is no wifi option. Please help me with this.

Bummer!

What device are you running and what WiFi card do you have?

If you could - what does 'lspci' or 'lsusb' spit out; anything with wireless?

pwned@pwned:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0c45:636b Microdia Hy-HD-Camera
Bus 001 Device 002: ID 0bda:d723 Realtek Semiconductor Corp. 802.11n WLAN Adapter
Bus 001 Device 004: ID 3151:3020 YICHIP Wireless Device
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Oddly, my little Hacktop had some hiccups with WiFi - it's registered as a USB device.. but internal lol Anyway, I was able to search the hardware ID 0bda:d723 and found RTL8723du. Painless install.. But - that should help identify what you've got.

Have you also tried running the Additional Drivers app from the menu? If you don't have Ethernet available for inet, you can use the installer for the Additional Drivers to load, if they're present on the USB. You could also use BT tether or USB tether to a mobile device for inet.

Yes I tried to install additional drivers using usb tethering but there's no update available. Wait I'll you all the information about the wifi card.



The r8168 driver is for your ethernet card. You need another driver for your wifi card, which isn't the same thing. Try following one of the solutions here

You are not the first person to have wifi issues on this forum. While i understand it may seem urgent, direct messaging members to fix a solution is not recommended (may even result in those members ignoring you).

Have a little patience and use the search of the forum and the internet to find possible solutions, in addition to any help offered here.

Your wifi is a Qualcomm Atheros QCA9377 card. Zorin is based on Ubuntu 20, for the purposes of your search. Any solution that worked in Ubuntu 20 will work in zorin 16.

1 Like

Thank you and sorry also, I'm new on linux that's why I messaged directly. Sorry for that. I will follow the steps given by you!

1 Like

There are a few here:

I would actually start at the bottom first and work my way upward.

1 Like

I tried it but nothing happened till no wifi :smiling_face_with_tear:

Did you have any instructions in your tutorial about using 'modprobe' to activate the new driver?

I am assuming you went through the guide and installed the firmware?

After my 8723du install, I had to use issue 'sudo modprobe -v 8723du' to activate the device.

For yours: 'sudo modprobe -v ath10k_pci' from what I'm seeing..

1 Like

Do please avoid vague responses like "didn't work". If there were any error messages, please relay them. Saying " I tried something" does not really tell anyone here what you really tried. Please list the steps you tried.

I did all these steps but nothing happened please help me

while I'm running: sudo apt-get update

output: 02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

while running : sudo apt-get install build-essential linux-headers-$(uname-r)
output:

uname-r: command not found
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Virtual packages like 'linux-headers' can't be removed
build-essential is already the newest version (12.8ubuntu1.1).
The following packages were automatically installed and are no longer required:
  adwaita-qt chromium-codecs-ffmpeg-extra coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1v5 coinor-libcoinutils3v5 coinor-libosi1v5 gstreamer1.0-vaapi
  heif-gdk-pixbuf libdouble-conversion3 libfuse3-3 libpcre2-16-0 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5svg5 libqt5widgets5 libva-wayland2
  libxcb-xinerama0 libxcb-xinput0 libxmlsec1 libxmlsec1-nss qt5-gtk-platformtheme qttranslations5-l10n
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

while running: echo "options ath10k_core skip_otp=y"|sudo tee /etc/modprobe.d/ath10k_core.conf

output: options ath10k_core skip_otp=y
whilw running: wget https://www.kernel.org/pub/linux/kernel/projects/backports/2015/11/20/backports-20151120.tar.gz

output: `--2023-07-28 08:07:42-- https://www.kernel.org/pub/linux/kernel/projects/backports/2015/11/20/backports-20151120.tar.gz
Resolving www.kernel.org (www.kernel.org)... 2604:1380:40e1:4800::1, 145.40.73.55
Connecting to www.kernel.org (www.kernel.org)|2604:1380:40e1:4800::1|:443... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://mirrors.edge.kernel.org/pub/linux/kernel/projects/backports/2015/11/20/backports-20151120.tar.gz [following]
--2023-07-28 08:07:43-- https://mirrors.edge.kernel.org/pub/linux/kernel/projects/backports/2015/11/20/backports-20151120.tar.gz
Resolving mirrors.edge.kernel.org (mirrors.edge.kernel.org)... 2604:1380:45d1:ec00::1, 147.75.199.223
Connecting to mirrors.edge.kernel.org (mirrors.edge.kernel.org)|2604:1380:45d1:ec00::1|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 15505007 (15M) [application/x-gzip]
Saving to: ‘backports-20151120.tar.gz’

backports-20151120.tar.gz 5%[====> ] 887.61K 19.5KB/s ckports-20151backports-20151120.tar.gz 29%[========================> ] 4 backports- 51%[=====backports-20151120.tar.gz 70%[===========================================================> backpor 77%[============> ] 11.40M backports-20151120.tar.gz 100%[=====================================================================================>] 14.79M 10.3KB/s in 25m 17s

2023-07-28 08:33:06 (9.98 KB/s) - ‘backports-20151120.tar.gz’ saved [15505007/15505007]`

Extracted by running: `tar zxvf backports-20151120.tar.gz

while running:cd backports-20151120 make defconfig-wifi make sudo make install`

output: bash: cd: too many arguments

running: git clone https://github.com/kvalo/ath10k-firmware.git

output: Cloning into 'ath10k-firmware'...
remote: Enumerating objects: 2662, done.
remote: Counting objects: 100% (833/833), done.
remote: Compressing objects: 100% (269/269), done.
remote: Total 2662 (delta 469), reused 690 (delta 441), pack-reused 1829
Receiving objects: 100% (2662/2662), 79.56 MiB | 147.00 KiB/s, done.
Resolving deltas: 100% (1358/1358), done.
Updating files: 100% (598/598), done.

running: sudo cp -r ath10k-firmware/QCA9377 /lib/firmware/ath10k/
running: sudo cp /lib/firmware/ath10k/QCA9377/hw1.0/WLAN.TF.1.0/firmware-5.bin_WLAN.TF.1.0-00002-QCATFSWPZ-5 /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin

Reboot

this command lacks the space in uname -r

It should be:

sudo apt-get install build-essential linux-headers-$(uname -r)

Try:

sudo modprobe -r ath10k_pci

sudo modprobe ath10k_pci

In your BIOS Settings, do you have an option to Enable PXE? If so, enable it.

Boot and test.

2 Likes

You might try updating your Linux kernel.

Kernel 6.2 supports Wifi devices that Zorin won't even detect.

Instructions on updating kernel:

Getting Error
prakash@prakash-Lenovo-E41-25:~$ sudo add-apt-repository ppa:tuxinvader/its-mainline sudo apt update && sudo apt install linux-generic-6.02
[sudo] password for prakash:
Error: need a single repository as argument
prakash@prakash-Lenovo-E41-25:~$ sudo add-apt-repository ppa:tuxinvader/its-mainline
Cannot add PPA: 'ppa:~tuxinvader/ubuntu/its-mainline'.
The user named '~tuxinvader' has no PPA named 'ubuntu/its-mainline'
Please choose from the following available PPAs:

  • 'jammy-mainline': Jammy LTS Mainline Kernels
  • 'kernel-build-tools': kernel build tools
  • 'lts-mainline': lts-mainline
  • 'lts-mainline-longterm': lts-mainline-longterm
  • 'my-random-ppa': ppa for random testingses
    prakash@prakash-Lenovo-E41-25:~$

You seem to have figured out already that you posted two separate commands on one line in terminal.
The second error resulted from you posting its instead of lts.
LTS stands for Long Term Support.