Wifi cannot connect

Hi everyone, total newbie here! :blush:
I installed zorin os lite on a acer travel ate with 4695agn network card

It sees wifi networks, but cannot connect to Internet in anyway, not even with ethernet.

How can I solve it?

Here an output I saw helped in other threads

When you say it cannot connect, do you mean that you can type in the WiFi password and it connects to your WiFi, but it doesn't ever let you load any web pages? Or do you mean it won't even connect to your WiFi?

The first one is likely a DNS resolution issue. The second one could be a number of possible issues, but usually it's due to typing in the wrong WiFi passphrase.

ping -c 10

Then try:
ping google.com -c 10

If the first one works, but the second one doesn't, it's a DNS resolution issue.

It sees my WiFi, then I type my password (very simple word) and there are two scenarios

  1. It doesn't connect to the WiFi, gives the spinning wheel for some seconds and then nothing
  2. If I change the connection to ad hoc in network configuration it connects to wifi

In both cases Firefox doesn't load any page

How are you setting up an ad hoc network in ZorinOS? I don't see the option for that. Is that an option in ZorinOS Lite? I'm using ZorinOS Core.

Zorin menu > Settings > Wi-Fi > Gear button

There's an option.

Now it connected with almost no issues to another wifi, but this is the result of the ping

Update: only on one of the three wifi I tried:

  1. it connected to the WiFi in client mode
  2. It worked after disabling ipv6 and putting ipv4 on auto

Now I'm updating the software, to see if the problem gets fixed. I'll post updates for future reference!

Update: it still has issues at connecting with various wifi, not depending on the security protocol, nor the router frequency (2.4ghz).

How can I try to solve this issue?

type this command in the terminal sudo journalctl -u NetworkManager -p 3 --since today and show us what u get

If I time since today/yesterday it says no data available, because the date before connecting to Internet was wrong.

If I remove the "since today" part it says this:

try running these command
sudo apt update

sudo apt upgrade network-manager

sudo systemctl restart NetworkManager

sudo apt-get install --reinstall network-manager (this command will reset ur wifi settings)

if none of these steps work, u might consider using other netwrok manager. u can install wicd using sudo apt install wicd after its installation gets completed, type sudo systemctl restart NetworkManager

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.