Wifi connected but no internet

Hi newbie here i am new to Linux and I only have like 10% knowledge of it I use zorin os pro on my major laptop and use zorin os core on my macbook the zorin os pro works well but the zorin os core on macbook as on problem I have a broadcom bcm4321 driver the driver is successfully installed by additional driver app and I can connect my router but i can connect to the Internet but I cam teather my phone connection to it and it works well I have tried many things on the forum but none seems to work

Please if you wish to help me feel free to ask me to run any command I really need this to work thanks.

Can you please open a terminal on the Macbook and run

sudo apt update && sudo apt install broadcom-sta-dkms

If that fails, due to the 5.13 Kernel, try the following package, instead:

sudo apt install broadcom-sta-source

Reboot when finished and test.

Source:
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

Hey I tried it and it installed but after rebooting it didn't work still can't connect to the Internet but the WiFi connects

Is it eg. broadband connection? Did you remember to set up your connection with your ISP? I recall I forgot to do this at one time when they switch to 5G and I couldn't connect to the net but I could connect to my router.

The connection is fine it works well the os won't connect to the Internet on wifi