WiFi connected, no internet

So I was messing around with proton, found this GitHub issue: How to properly autoconnect on startup · Issue #44 · ProtonVPN/linux-cli · GitHub

And I added this command that was commented here to the startup: How to properly autoconnect on startup · Issue #44 · ProtonVPN/linux-cli · GitHub

/usr/bin/protonvpn-cli ks --off && /usr/bin/protonvpn-cli c -f && protonvpn &

Then I restarted my laptop.

Internet stopped working, the VPN didn't even work, so I completely uninstalled it, both protonvpn and protonvpn-cli, restarted my laptop, still the same issue. I restarted my router, still the same issue. I realize that I shouldn't have just added some random command to the startup and tested it but for some reason I thought nothing would go wrong.

Any help would be GREATLY appreciated, I'm still very new to Linux and Zorin so I don't have much experience, I tried many solutions that I found online using my phone but none worked, some suggested running sudo apt-get update but there's literally no internet so that didn't work.

Can you try temporarily connecting your computer to the internet through your Phone Provided Hotspot?

Others have experienced ProtonVPN net connectivity as well:

1 Like

I ran into the same issue when I was still using proton, make sure it hasn't changed your wifi settings. Usually the easiest way is to forget your connection delete the profile if there is one and reconnect fresh. Usually it makes some change to Mac address behavior that your router doesn't like.

Check out pia VPN.


I did as you said, made a new profile and reconnected to the internet with it, but the internet issue was still present

That Reddit post is about the problem but on windows, I couldn't make use of it to solve my issue since I'm on Zorin.

It shows that ProtonVPN is the culprit.:wink:

That's true, but protonvpn is completely removed from my laptop, and there is no settings in the WiFi related to protonvpn. I'm aware it caused the issue but that doesn't solve my problem

1 Like

Also I just tried connecting the ethernet cable and I get the same issue, "DNS address could not be found." When I try to open any website. I can't try the hotspot method since I don't have mobile data.

Can you try

sudo nmcli connection delete pvpn-killswitch

sudo nmcli connection delete pvpn-ipv6leak-protection


First command said it couldn't delete the unknown connection "pvpn-killswitch".
Second one worked successfully, ethernet works! I'll try with the wireless connection and let you know the result

Edit: your solution works for wireless too, thanks so much!

1 Like

Sorry for my lack of clarity above. I was in the middle of looking into this and reading that thread and stopped to respond to your comment here - I meant to post the above in that reply... but my clumsy finger banged the crtl or shift key and the post submitted instead.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.