Wifi doesn't work, Zorin 17

So, I installed Zorin 17.1 Pro on my girlfriend's old laptop, but I cannot seem to get wifi to work or even recognized.
Maybe someone here knows what to do.

The laptop is a TOSHIBA Satellite P755.

lshw -C network gives:

       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 05
       serial: dc:0e:a1:4d:37:d7
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=6.5.0-26-generic duplex=full firmware=rtl_nic/rtl8105e-1.fw ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:16 ioport:e000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff

When I do lspci -v | grep -A20 Ethernet, I get this:

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 05)
	Subsystem: Toshiba Corporation RTL810xE PCI Express Fast Ethernet controller
	Flags: bus master, fast devsel, latency 0, IRQ 16
	I/O ports at e000 [size=256]
	Memory at f0004000 (64-bit, prefetchable) [size=4K]
	Memory at f0000000 (64-bit, prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: r8169
	Kernel modules: r8169

03:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 30)
	Subsystem: Toshiba Corporation SD/MMC Host Controller
	Flags: bus master, fast devsel, latency 0, IRQ 19
	Memory at f7d03000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: sdhci-pci
	Kernel modules: sdhci_pci

03:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 30) (prog-if 01)
	Subsystem: Toshiba Corporation Standard SD Host Controller
	Flags: fast devsel, IRQ 19
	Memory at f7d02000 (32-bit, non-prefetchable) [size=256]

Does access denied mean anything?
When I run iwconfig, there doesn't seem to be a wlan0 or similar:

lo        no wireless extensions.

enp1s0    no wireless extensions.

I am also trying a tp-link usb wifi adapter.
It is clearly recognized, lsusb:

Bus 002 Device 004: ID 2357:011e TP-Link AC600 wireless Realtek RTL8811AU [Archer T2U Nano]

But wifi still doesn't work.
In fact, there is no wifi recognized in the settings.
Looking for drivers in the update settings doesn't find any wireless drivers.
There is no wifi switch in the BIOS settings, no physical wifi switch on the computer, only a fn button that indicates being a wifi switch, however, doesn't do anything.

Does anybody here know what to do? Any help will be appreciated, thanks.

Did the Wifi worked on the Machine before You installed Zorin?

What about the terminal output of

lspci -knn | grep Net -A3

Absolutely nothing.

I am not entirely sure. I think it did work with the USB adapter, but stopped working before I deleted Windows and installed Zorin.

Need something to work with, here... :stuck_out_tongue:
If the card is completely unrecognized, it either may have failed or is completely unsupported.
It might be a lot easier and more reliable to get a USB Wifi adapter.

Thanks for trying. :smiley:

Yes, so I do have a USB adapter plugged in, and it is recognized, see above, but I wifi is still not found, and drivers are not found through the settings.
Do you have an idea how to get that one to work?

I would first try the available drivers with DKMS. If that does not work out, you can try the various ones on github.
Let's start with the available DKMS:

Ensure you have a net connection either by Ethernet or mobile phone hotspot connected by USB tether.
In terminal run

sudo apt update && sudo apt full-upgrade

Once all packages are upgraded, run

sudo apt install rtl8812au-dkms

That did not do anything, unfortunately.
I guess, I'll have to try github.

Should I uninstall the dkms one first?

You can remove it with

sudo apt remove --purge rtl8812au-dkms

From github:

sudo apt install git build-essentials

git clone https://github.com/morrownr/8821au-20210708.git

cd 8821au-20210708

sudo ./install-driver.sh


Goodness, that seems to work. I had trouble establishing a wifi connection first, but then switched to another USB slot and then it worked. I guess the whole computer is a bit broken.
Anyways, thanks. I've spent the whole day on this computer already.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.