Wifi extremely slow

Wifi is very very slow. Speedtest.ent takes ages to load and fails to do a test.

Tested Mint distro and i get 90mbps sapeeds with no issues....

How can i fix this??

Could you please try this Facing slow internet In Zorin Core 16 ?

1 Like

Also here is a DNS change that may help from our tutorial section. scroll down the first post and see also what @337harvey inputs as well Things you must do after installing zorin OS 16

2 Likes

I tried this by switching it from 3 to 2

Tried many commands i found on ubuntu os too.

tried this too, still getting under 10mbps speeds, better than before tho

1 Like

did you reboot after making changes?

If you did try :
sudo apt update &
sudo apt upgrade

There may be update for your system which would help by the way to know

Please include when posting your system specs as this helps the Mods and others when assisting you in a resolution to your problem

System specs:

CPU
GPU
RAM
HD (Hard drive)
ZORIN OS
Make of Computer
Model

Edit : also try in terminal also

sudo lshw -C network

and upload it here

2 Likes

Based on your other thread you have the intel ac 9560.
See: Linux* Support for Intel® Wireless Adapters
Pretty sure the kernel is > 4.14 but I advise checking with uname -a

2 Likes

You can try checking if there are more drivers available for your system. Install all the drivers (including closed source ones if needed). I've had something like this before. I did an update and also used protonvpn beta for linux. The next day, Internet was stupid slow not a single site loaded. I installed Zorin OS again and it worked even with all updates installed. It was Protonvpn's fault though since it was through the terminal.

Causes for your problem might be:

  1. Needs more drivers
  2. An Application made some changes that might have broken the internet for Zorin OS.

Tried reinstalling zorin, didnt work either. I wasn't a really smooth experience starting with linux. Mostly hardware issues but still, I have been fixing issues for the past 48 hours. I tried linux mint and didnt experienced a single issue yet. I really wanna use zorin, i appreciate the looks but unfortunately I am not able to use it as a complete linux noob. I hope these issues get fixed in future releases.

My problem with Wifi was secure boot, which I mistakenly enabled during installation. Is your secure boot enabled? If so, try disabling it. You would need to get into your BIOS to check and disable it.

3 Likes

Sorry it didn’t work out but I’m glad mint works for you. I’m guessing updating firmware didn’t help?

1 Like

unfortunately it didnt work

It was disabled

I was reading about this same problem in another post and it was suggested that it is a Power Management issue. Some one named StarTreker I think solved it. I don't remember where it was but it is worth a look.