Wifi gets wrongfully detected as metered connection

So I am connected to my mobile hotspot (because our DSL has stability issues lately) I have unlimited data so the Connection isn't set as metered in The wifi settings:

But somehow the software center detects my connection as metered, so it stops automatic updates.

Can anyone help?

This is a flaw in gnome-software. It relies on glib / GNetworkMonitor instead of user input settings.

Things you can try:
In your Zorin Settings network manager, ensure that ethernet and wifi are both set to "no" for metered since the default is to "guess" if unknown.
Restart gnome-control-center completely (or just reboot), then in terminal check the value for metered:

busctl get-property org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.NetworkManager Metered

Should be value u 2

Note that this bug will also affect Snap Store and Flathub.

I can not find where I can switch the setting from guess to no...

I am sorry, I am typing hurried and it gets short and unclear sometimes.

I do not use Gnome Desktop so am not really familiar with its layout, either.

The "guess yes" function is written into the code to handle cases where no selection is made in user settings, so it will not show up in the settings GUI.

If you can give me a few minutes, I will log into an instance of Zorin on Gnome and try to find the settings path.

take your time :slight_smile:

Ok I am logged into Gnome Desktop now (and already feeling the effects of the Kryptonite...)
Clicking Zorin App Menu > Settings...
This opens Gnome Control Center.
Wifi tab on the left pane - I see my network name and a Gear Icon on the far right.
Click the Gear icon - Metered is off - At this point, I think I duplicated what you have done.

Below that is Network in the left pane. Repeating above - I click the Gear Icon on the far right and a similar window opens- Metered connection off.

IF both of those are properly set and the problem persists... please open a terminal and find your exact network name with this command:

nmcli -t -f GENERAL.CONNECTION --mode tabular device show $DEVICE | head -n1

copy that name and paste it in a gnote or notepad
then copy and paste this command into terminal replacing (NETWORKNAME) with what you copied above (no parenthesis):

nmcli -f connection.metered connection show (NETWORKNAME)

This will show connection.metered: and "unknown", "no" or "yes." You need "no."
This command will set a connection as NOT metered:

nmcli connection modify (NETWORKNAME) connection.metered no

Thank you! That helped!!!

2 Likes