Wifi gone after update, even on new/clean install

Hello, I have a cheap laptop with no ethernet port.
I installed Zorin Lite 16.3 on it, there were wifi networks visible during the installation and after install with no issues.

Then I went to automatic update settings, installed updates and since then wifi is not working. I think I spotted some 'firmware upgrade' among the packages, but I'm not sure.

I tried to do a clean install of Zorin again, but the wifi is not working anyway. Connection option during the installation only lists 'Realtek Semiconductor Corp.' in the network list, while I previously could see available wifi networks there.

Any ideas about this?
Thank you

Is there any way you could download 16.2 from here?

https://mirror.webworld.ie/zorinos/16/

If you still had it installed, you could have tried booting from an earlier kernel.

It's possible that the update might have caused compatibility issues with the Wi-Fi driver. You can try troubleshooting the problem by checking if there are any additional drivers available for your Wi-Fi OR roll back to previous version.

@ebb156 With 16.3 Lite. Have you tried booting an older kernel generic version via grub "Alternative Options for Zorin" menu item?

Thanks for the help. To be honest I am not sure what is really going on, I tried older kernel and the wifi came on, but now it works with the newer one too. Maybe it just needed a day's rest.

As you now seem to have working wifi, I have marked your last post as "Solution".
If that changes, it can be un-marked and diagnosis continued.