Wifi is seriously slow in zorin pro 16

I've tried the solutions listed in the forum, but it still doesn't work

Hi and welcome to the forum.
Can you tell us more about your PC spec and WiFi card.

Are you dual-booting Zorin and Windows?

Also, have you gone to Software Updater, set source to "Main Server" and checked for Additional drivers?

my WIFI adapter is intel ax201

I did switch to "Main Server", but it shows "no additional drivers"

I found this on a search:

Have a look at this:

1 Like

Also, check and see if you have the same WiFi speed problems with Bluetooth turned off.

Changed from Feedback to Hardware Support.

There are several things that effect network speeds. This could be your wifi driver, the standards that the card support, interference with competing frequencies as well as the need to reboot your router (something that should be done at least once a month). Then there is the amount of traffic when you utilize the web, what dns servers you use and if there are competing communications on the router (streaming services and gaming connections are the biggest culprits).

You may want to check if your adapter is supported on the current firmware and if not you can get a newer firmware which supports your hardware.

The reference table of Wireless adapters and corresponding kernel versions is available by the link:

The latest FWs are available by the following link:​ ​

You may want to check your network settings to make sure you are using WPA2 and AES. Without some more details it would be difficult to narrow this down.

Is it a specific site that is slow or all of your internet travels? Is it a game or streaming or torrent site? Have you tried adjusting your dns addresses to point to Google or cloudflare? What is the output of iwconfig -a. Please be sure to block out your public ip address if one is assigned to your household. (It will be any ip not starting with 10, 172.16 or 192.168... these are the private addresses and not publicly accessible without much work).


Post the output of lshw -class network

I believe it's a driver problem and you need proprietary drivers to fix the problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.