Wifi Network-Activation-Failed [Core] [Dual-Booted With Win11] [TP-Link Wifi Adapter]

Wifi Not Connecting...
When i try to connect to wifi i get a notification which says "Activation of Network Failed" , I use TP-Link Wifi Adapter (TL-WN823N)

And i Use ZorinOS 12 Core
And i Dual-Booted With Windows 11

First I Installed Ubuntu 20.04 LTS and i Had the same Problem, i thought its might be a OS problem and installed Zorin but now i have the same problem
Specs Of My PC:
CPU : AMD Ryzen 3 2200G,
Ram : 16GB DDR4
Graphics Card : Nvidia GT 730 , VRAM 4GB,
Wifi Adapter : TL-WN823N
Storage :
- WD SSD 255GB (Windows 11 installed on)
- HDD 1tb (Zorin Installed On A Partition With 80GB)

Thanks You

TP Link websites list the Wi-Fi adapter is supported with Linux. What is your kernel version?

Hi and welcome to the forum.

In your Software Updater check sourse is set to "Main Server", then see if any Additional Drivers are available to you.

Also. Seems they have Linux drivers on TP-Link website. Download for TL-WN823N | TP-Link

1 Like

So Does That Means My Adapter Does Not Support Zorin16?

Thanks You For Replying,
I will try to do it right now

It should work, it's supported, maybe you should try @zabadabadoo solution.

If that does not work try the commands from below, open the terminal and write

git clone https://github.com/clnhub/rtl8192eu-linux


  • Note this should work for TL-WN823N V3
1 Like

There is also more here regarding that error

I read the documentation that comes with the Driver install. It's for Ubuntu 14.01, but it should work on ZorinOS 16 as well.

ls #directory of the driver ←(Access the directory of driver)
sudo make ←(Compiles the driver)
sudo make install ←(Installs the driver)

1 Like

Thank You So Much I Been Trying To Solve This for 3 days. But My Internet is a bit Slow

1 Like

First Of All Thank You For Reply,
I tried That which didnt work

Now My only Problem Is Why Is My internet a bit slow?

Have you tried removing the WiFi Adapter and plugging it back in whilst in ZorinOS. Maybe in a different USB port.

NVM, i made it working as normal. I just restarted my router, the speed is normal now.. Anyway Thank You Guys For Replying. IDK why i wasted 3 days for searching for this instead of making a forum
Thanks You Again


This is quotable.
Sometimes, searching helps. Sometimes, it just confuses and getting a little extra help makes all the difference.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.