Wifi not connecting automatically at start

Hi,
I upgraded my mom's computer from Zorin Lite 15 to 16. We got now a problem we didn't have before:
When starting the Wifi does not connect automatically to the router.
The symbol shows up, it can be connected manually without a problem and the connection stays but doesn't connect automatically.
Also happens after reboots.
Any ideas?

(Answering might take longer, I need to get into the computer via remote control and it's not always switched on)

Is the wifi Hidden?
Can you please try:

nmcli connection show

Note the SSID. Then run this, ***changing SSID tp the SSID you noted above:

nmcli connection modify SSID wifi.hidden yes

Change SSID the same here:

sudo nmcli con mod SSID connection.autoconnect yes

Finally, restart the service:

sudo service network-manager restart

1 Like

I have this problem and I have to set the password for the WIFI accessible by all.
Select the group icon to the right of the password field and set to "Store the password for all users".

Now when I boot up, and before I login, the WIFI is connected.
I did this as I had issues attaching to a VPN automatically. I use nm-connection-editor to enable the WIFI to automatically connect to the VPN on startup).

3 Likes

Thanks for the answers!

@jgordon: thanks, I test it.
Is the change needed from the admin's user or the desktop user (having both on the computer)?

@aravian

nmcli connection show

NAME                          UUID                                  TYPE  DEVICE 
BBKR-WLAN                     3fcb37d6-2c7b-4b52-90c6-599105afb430  wifi  wlp1s0 

No SSID. But the network is not hidden. It just doesn't connect automatically

1 Like

What about this suggestion:

Okay, I think this worked for some reason: go to 'Network Connections', select the gear to edit the connection, go to the 'Wi-Fi Security' tab, and in the 'Password' box, select 'Store the password only for this user'. Save, restart, and bam it connects automatically. Strange issue.

Well, it's been on "only for this user". I think it might be, because the WIFI was established by the desktop user and not the admin.

In nm-connection-editor, Under General tab, I assume that Connect Automatically with priority is checked and set to 0?

Yes, first thing I did

1 Like

Ok, Problem solved.
As mentioned the setting is an admin and a desktop user
The desktop user was the one to connect to the wlan.
@jgordon 's solution is not working from the desktop user account.

But disconnecting the wifi from the desktop user's account, then logging into the admin user, connecting to wifi from there and then following @jgordon 's solution worked.
Weird issue...

Thanks a lot for your help!