WiFi or Ethernet not working

Hey there
So I have this :point_down:t2:

And this is not working in Zorin. It has Bluetooth, WiFi and Ethernet port. Non of them are working. And I have an Ethernet port in my motherboard, which is also not working either. The only was to connect to internet is USB Tethering. How can I fix that?
Valiant Boy

You may be experiencing the same thing as this person:

Ok let's see. Thank you sirπŸ˜„

Sir, how to install the .sh file? I have extracted that. What's next? Cause I haven't installed any additional drivers in ZorinπŸ˜…

Actually I have figured that out. But I have an error now? How can I fix that?
Screenshot from 2022-06-19 23-57-58

You can go back in and rmmod later if needed. What is important currently is whether the software installed.
You can modprobe the new driver, if needed.

Its not installing, I have tried tons of command but non of them are working. Please Help me in removing the old driver and installing the new one.
Valiant Boy

This scares me... Without knowing what commands have been run, re-tracing the steps in order to troubleshoot this can get tedious.

Which driver do you need removed?
Did you run any modprobe commands or blacklist additions or removals?

So i have found this post related to my Ethernet card
and this also

Ask Ubuntu suggested that I should r8101 driver. So i download the driver for the real tek website and extracted the file. Inside the driver's folder i found a autorun.sh file. There i had Opened the terminal and enter the command
sudo bash autorun.sh
After some steps the driver was successfully. I had tested that by
inxi -Fx
After a reboot, I opened Network section in Settings, there was now an option for PCI Ethernet. Afterwards I had connected my WiFi to my computer via ethernet cable but nothing happened. Internet was not connect, in fact it is looking something like this

Its saying that cable is still unplugged. And there is no option for Wifi. What should i do now.
Valiant Boy

From above^

Actually I had just

sudo bash autorun.sh

And it automatically removed r8169 Driver and installed r8101 driver.

No. I haven't used that command yet. I mean I had tried but unfortunately it didn't worked!

Hmmm... the 810xE is included in the r8169 driver, but not in the 8168. You removed the 8169?

cat /etc/modprobe.d/blacklist.conf

Relay the results here, too -we can see if your necessary driver is blacklisted.

Here we go

> # This file lists those modules which we don't want to be loaded by
> # alias expansion, usually so some other driver will be loaded for the
> # device instead.
> # evbug is a debug tool that should be loaded explicitly
> blacklist evbug
> # these drivers are very simple, the HID drivers are usually preferred
> blacklist usbmouse
> blacklist usbkbd
> # replaced by e100
> blacklist eepro100
> # replaced by tulip
> blacklist de4x5
> # causes no end of confusion by creating unexpected network interfaces
> blacklist eth1394
> # snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
> # hardware on its own (Ubuntu bug #2011, #6810)
> blacklist snd_intel8x0m
> # Conflicts with dvb driver (which is better for handling this device)
> blacklist snd_aw2
> # replaced by p54pci
> blacklist prism54
> # replaced by b43 and ssb.
> blacklist bcm43xx
> # most apps now use garmin usb driver directly (Ubuntu: #114565)
> blacklist garmin_gps
> # replaced by asus-laptop (Ubuntu: #184721)
> blacklist asus_acpi
> # low-quality, just noise when being used for sound playback, causes
> # hangs at desktop session start (Ubuntu: #246969)
> blacklist snd_pcsp
> # ugly and loud noise, getting on everyone's nerves; this should be done by a
> # nice pulseaudio bing (Ubuntu: #77010)
> blacklist pcspkr
> # EDAC driver for amd76x clashes with the agp driver preventing the aperture
> # from being initialised (Ubuntu: #297750). Blacklist so that the driver
> # continues to build and is installable for the few cases where its
> # really needed.
> blacklist amd76x_edac

Nothing there that could explain it...
You have the 810xE ?
I would use this driver for that card:

Yes Sir, I have 810xE.

Sir I had downloaded the driver from the provided link of official website of RealTek in this Github page and installed that. Still no results. What should I do now Sir?
Valiant Boy

Yes, I know... But I would trust the link I provided more. The reason is; Realtek does not really care about Linux and can be pretty lackadaisical about ensuring up to date drivers.
Whereas the Linux maintainers relay on working drivers and are likely to have them working.

I think I wasn't that clear. Before installing any drivers I had visited this GitHub page. But I didn't found any download link for the Particular GitHub Driver. If you can provide me that I would definitely install that driver. The only thing I found on the GitHub page was the download link for official Driver of Realtek.
Valiant Boy

If you look on the upper right side, you will see a button marked "Code"
In this image, it is Bright Green:

Click that button and select Download ZIP
In your ~/Downloads directory, select the Zip and "extract here", then enter the extracted directory.
On the Github page, scroll down a bit for the install instructions:

1 Like

Thank you sir. Let me do it

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.