Wifi Prompts for password over and over

Hello, i just installed Zorin Core 17.1. and the wifi prompts me for my password over and over again without connecting.

I installed all updates without a problem, but this did not resolve my issue.

sudo apt update
sudo apt upgrade

This didn't resolve my issue. So i tried making sure the wifi power saver mode was off.

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

resulting in:

wifi.powersave = 2

This again, didn't resolve my issue.
I then attempted to update the linux firmware drivers:

sudo apt install git
git clone https://kernel.googlesource.com/pub/scm/linux/kernel/git/firmware/linux-firmware
cd linux-firmware
sudo mkdir /lib/firmware/updates
sudo mv * /lib/firmware/updates/
sudo update-initramfs -u

This got my bluetooth working, but did not resolve my wifi issue.

I then attempted connecting to the hotspot on my phone which works. So, i think may be an issue connecting the my TPLink AX4400 which merged the 2.4 & 5ghz bands into a single SSID. I created seperate SSIDs for 2.4ghz & 5ghz, but this also didn't resolve my issue. Has anyone had this type of issue and been able to resolve it?

Sytem Info

  Kernel: 6.5.0-28-generic x86_64 bits: 64 compiler: N/A Desktop: GNOME 43.9
    Distro: Zorin OS 17.1 base: Ubuntu 22.04 LTS Jammy
  Type: Laptop System: CHUWI Innovation And (ShenZhen) product: GemiBook XPro
    v: N/A serial: <superuser required>
  Mobo: N/A model: N/A serial: <superuser required>
    UEFI: American Megatrends LLC. v: EM_IDL8329_SUB1_V2.0.22 date: 09/28/2023
  ID-1: BAT0 charge: 38.0 Wh (100.0%) condition: 38.0/38.0 Wh (100.0%)
    volts: 7.6 min: N/A model: Intel SR 1 SR Real Battery status: Charging
  Info: quad core model: Intel N100 bits: 64 type: MCP arch: N/A rev: 0
    cache: L1: 384 KiB L2: 2 MiB L3: 6 MiB
  Speed (MHz): avg: 2638 high: 3373 min/max: 700/3400 cores: 1: 3373
    2: 3332 3: 3149 4: 700 bogomips: 6451
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel vendor: nCipher Security driver: i915 v: kernel
    bus-ID: 00:02.0
  Device-2: Tripath USB Camera type: USB driver: uvcvideo bus-ID: 1-6:2
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel Graphics (ADL-N)
    v: 4.6 Mesa 23.2.1-1ubuntu3.1~22.04.2 direct render: Yes
  Device-1: Intel driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound Server-1: ALSA v: k6.5.0-28-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Intel driver: iwlwifi v: kernel port: N/A bus-ID: 00:14.3
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-10:3
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter>
    bt-v: 3.0 lmp-v: 5.2
  Local Storage: total: 238.47 GiB used: 14.23 GiB (6.0%)
  ID-1: /dev/sda model: AirDisk 256GB SSD size: 238.47 GiB
  ID-1: / size: 233.18 GiB used: 14.22 GiB (6.1%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 511 MiB used: 6.1 MiB (1.2%) fs: vfat
    dev: /dev/sda1
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swapfile
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 290 Uptime: 37m Memory: 7.49 GiB used: 3.73 GiB (49.7%)
  Init: systemd runlevel: 5 Compilers: gcc: N/A Packages: 1907 Shell: Bash
  v: 5.1.16 inxi: 3.3.13

rfkill list all

0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

iwconfig (note: this is while connected to mobile hotspot)

lo        no wireless extensions.

wlo1      IEEE 802.11  ESSID:"Samsungs24"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 2E:6A:F6:27:81:16   
          Bit Rate=72.2 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=49/70  Signal level=-61 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:41   Missed beacon:0


Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 058e:3864 Tripath Technology, Inc. USB Camera
Bus 001 Device 003: ID 8087:0026 Intel Corp. AX201 Bluetooth
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


00:00.0 Host bridge: Intel Corporation Device 461c
00:02.0 VGA compatible controller: Intel Corporation Device 46d1
00:04.0 Signal processing controller: Intel Corporation Alder Lake Innovation Platform Framework Processor Participant
00:08.0 System peripheral: Intel Corporation Device 467e
00:0a.0 Signal processing controller: Intel Corporation Platform Monitoring Technology (rev 01)
00:12.0 Serial controller: Intel Corporation Device 54fc
00:12.6 Serial bus controller: Intel Corporation Device 54fb
00:14.0 USB controller: Intel Corporation Device 54ed
00:14.2 RAM memory: Intel Corporation Device 54ef
00:14.3 Network controller: Intel Corporation Device 54f0
00:15.0 Serial bus controller: Intel Corporation Device 54e8
00:15.1 Serial bus controller: Intel Corporation Device 54e9
00:16.0 Communication controller: Intel Corporation Device 54e0
00:17.0 SATA controller: Intel Corporation Device 54d3
00:19.0 Serial bus controller: Intel Corporation Device 54c5
00:19.1 Serial bus controller: Intel Corporation Device 54c6
00:1a.0 SD Host controller: Intel Corporation Device 54c4
00:1f.0 ISA bridge: Intel Corporation Device 5481
00:1f.3 Multimedia audio controller: Intel Corporation Device 54c8
00:1f.4 SMBus: Intel Corporation Device 54a3
00:1f.5 Serial bus controller: Intel Corporation Device 54a4

Last note: I booted to Fedora 40 workstation, and i was able to connect to the SSID without issue.

Any and all help would be greatly appreciated.

update: wifi also works in Ubuntu 24.04, but not Mint 21.3, so, this is definately a hardware driver issue. There must be something i'm missing to get that to the latest.

You could try upgrading the kernel so it match the one in Ubuntu 24.04.

have you tried rebooting your router ?