Wifi RTL8822CE Not recognized Zorin 16.3

Hey bro i have some wifi dongle not found problem i tried disabling the fast boot in windows and disabling the secure boot in bios but it didn’t work. The problem is same in ZOS 16.3 wifi dongle bot found

Can you please post the terminal output for

sudo lshw -C network

madrix@enon:~$ sudo lshw -C network

*-network UNCLAIMED

description: Network controller

product: RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Realtek Semiconductor Co., Ltd.

physical id: 0

bus info: pci00000:01:00.0

version: 00

width: 64 bits

clock: 33MHz

capabilities: pm msi pciexpress cap_list configuration: latency=o

resources: ioport: 3000 (size=256)


*-network DISABLED

description: Ethernet interface

physical id: 2

logical name: virbro-nic serial: 52:54:00:57:0: a1

size: 10Mbit/s

capabilities: ethernet physical

configuration: autonegotiation=off broadcast=yes driver=tun driverversion

=1.6 duplex=full link=no multicast=yes port=twisted pair speed=10Mbit/s

Is this your Wifi Dongle or the Built In WiFi card?

It is the built in my laptop

Are you using the Wifi Dongle because the built in is not working?

Can you provide the make and model of the Wifi Dongle?

Bro sorry if If my description is mistaken but the problem is in my laptop and im not using any external dongle or something . The os shows wifi dongle is not found but in windows wifi is working properly the wifi is built in that comes in laptop

Ah, I see. I will adjust the thread title.
A Dongle is a USB supplied external device.

The built in is usually just referred to as the "card."

Whoever names all these things needs a better job.

Can you connect that computer using another means like Mobile Phone on Hotspot and connected to the notebook computer with a USB cable and then run:

sudo apt update && sudo apt install rtl8821ce-dkms


Man you are a lifesaver thanku from my bottom of heart this worked..

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.