Wifi WPA2 Enterprise

I cant connect to my universitys wifi, since it uses WPA2 Enterpise. I am able to connect to WPA2 Personal Wifi. I am also able to connect my phone and other devices to my universitys Wifi, but not my Zorin Laptop. I searched a lot for it online and it seems that this is a problem with Ubuntu (Fedora for example i read, should work). I also found a few posts on how to solve the problem, but nothing did work for me (also possible that I am just to dumb to follow this steps correctly) (https://itectec.com/ubuntu/ubuntu-cant-connect-to-wpa2-enterprise-peap-network/).

I am currently using my smartphone for USB-Ethernet, but that cant be a permanent solution.

My Setup: Zorin OS Core
internal Wifi Adapter/Module ?: Broadcom Limited: BCM43142 802.11b/g/n (I had to install drivers for it manually, but I don’t think this has something to do with this, since the Problem is only with WPA2 Enterprises and not with for example my Wifi at home which uses WPA2 Personal)

I know my username and password are right (since I am able to connect other devices to the Wifi). I also tried almost every Setting to connect to it I found.

That link shows a solution that begins with:


Could you post the full copy you created?

I sadly cant do that, since whenever I open the file according to the tutorial it is empty. I tried to just copy what should be there in it, but it changed nothing.

I was able to connect to eduoram several times. It only works after booting from Windows and it only works for an hour or so. After that the connection breaks down and wont reconnect.

I can out of the GUI see what settings (or at least a few of them) worked with eduoram. ipv6 and ipv4 are set on auto for example.