Will steam/proton gaming get fixed?

Recently put Zorin on my OS Drive, looking to ditch Windows soon.

However, my games in Steam refuse to launch. After clicking Play, it seems to do nothing and then the button reverts to 'Play'.


  • Compatibility / Steam Play is enabled
  • I have tried all Proton options
  • I have tried both the .deb package and the Flatpak version
  • Read all posts here regarding gaming / steam etc.
  • Installed with Nvidia driver

I will hop to a different distro if I can't get this solved..



Ryzen 5950X
Nvidia RTX 4090

Assuming that you did all the required to exclude a system or software fault, the answer is ABSOLUTELY YES, unless Valve Corporation likes losing users they will fix.

I just don't understand why it doesn't work on my end. Any changes on Zorin OS 17?

My steam works well, i have a problem with steam, just reinstall and works great.

Vulkan drives show when i start the game.

See a sneak peek at Zorin OS 17. I don't know about how drivers are used, I think I have Vulkan, too, but I don't know if it's used when I play. For me it's yet a victory that the game works as intended.

Are you using Wayland as the display manager? I've heard that can cause problems with steam games. To make sure you arent using wayland, on the user login screen before reaching the desktop, click the settings button that appears on the bottom-right side of the screen; there should be the options "Zorin Desktop" and "Zorin Desktop on Wayland". Select the one that doesnt say Wayland and see if it works

You could also see if the games you are trying to run are supported by proton:
If they arent supported, there isnt really much you can do other than waiting until it becomes supported with an update

I havent changed anything on the login screen, I'll check. I just installed Zorin OS 17 as well. Same story.

Games I have been trying are all Proton supported.

Just tested my Proton games (well... the one I currently used) and they seems to work fine. (Z17 beta). I got a Nvidia card as well a 1070.

I have used Steam with Proton for a long time without any trouble.
Recently, in the last few weeks, one game stopped launching. Then, in the last week, that turned into three not launching.
My only solution seemed to be a complete purge of Steam and reinstall. In the end, I did not lose any games in my library. I did lose some saved data on one game only but that could be my own fault and I do not care about it (I also uninstalled and reinstalled that game.)

I am heavily inclined at this point to think that this is a fault with Steam, not Nvidia or GnuLinux/Zorin OS.

1 Like

That's an odd issue, I'll just ask a couple of questions to get a clearer picture of what may be the issue

  • Have you tried running Steam with -console?
    This gives you an extra tab in steam that's useful to see what's happening when a game is being launched.
  • For the Flatpak, are Nvidia Flatpak runtimes installed?
    These should be automatically installed and updated when you have the Nvidia Drivers on your system, but bugs can happen at any time. You can check if you need updates for that simply by running flatpak update in a Terminal Window.
  • Does it only happen for certain games?
    If so, this is most likely not an issue with Proton itself
  • Do other distributions of Proton/Wine work?
    This could be with something like Bottles or Zorin's own Windows App Support.
  • Are you using Wayland?
    Nvidia's proprietary drivers notoriously cause issues with the Wayland backend, which is why it's usually disabled as the default when using Nvidia's drivers. but JUST to make sure, try running echo $XDG_SESSION_TYPE in a Terminal window, and see if it either returns wayland or x11.
1 Like

Multiple games in my library, sadly. All proton supported ones.

I have tried running in terminal with flatpak version, didn't see anything interesting but I'll check again.

Im pretty sure I tried a non steam game using Zorin WAS which worked the first time i installed Zorin..

I will check on Wayland today and the Flatpak updates.

Thanks everyone.

Btw, do yall recommend Flatpak or the native package?

Which Steam package are you on? I had that exact issue in the past with Steam from the repos installed. Once I switched to flatpak or snap it ran without issues.

Flatpak is more universal, in the sense that you get the exact same version of Steam across multiple systems and Linux Distros - BUT it makes dealing with external storage a little more annoying as you gotta give Steam access to that with something like Flatseal first.

Which Steam package are you on? I had that exact issue in the past with Steam from the repos installed. Once I switched to flatpak or snap it ran without issues.

Same issue on both for me.. I haven't gotten around to trying the Wayland fix / Flatpak update yet. I'll post an update once I have.

Have you tried X.org?

What's that?

Okay so somehow I managed to get it working (Zorin OS 17 Beta):

  • Removed Steam which was installed through store (.deb, also tried flatpak before)
  • sudo apt update / sudo apt upgrade
  • sudo apt install steam
  • launch steam (terminal; 'steam' command)
  • enable steam compatibility mode (as usual)

That's it! So far I launched:

  • Monster Hunter World
  • Dave the Diver
  • Nova Drift
1 Like

Apart from Wayland, you can also start your session in X.org. Because Wayland is known to have issues with flatpaks.

There's also other issues with Wayland - like performance hit and glitches with games (tested on my Fedora 39 with the latest stable Wayland).


I haven't ever used Wayland on Zorin so I wouldn't know, but it makes sense. Maybe my solution above can be pinned for people who have issues when installed from the store/flatpak.

Using the terminal did the trick for me.