Windows dual boot not executing

Just installed Core selecting dual partition option but although Zorin loads when I select the widows partition the screen blanks and hangs - forever. As I am new to Zorin and Linux all help would be appreciated.

Welcome, garethandalex.
If you are getting a black screen, please look at Aravisian’s first post here: [SOLVED] Black screen after install
Can you tell us more about your machine?
Is it two separate drives you are installing on or the same one?
Did you select the “Something else” option on install or a different one?
Do you have UEFI enabled/disabled?

hi carmar
I’ll take a look at the post thanks.
A Son Vaio laptop, a single drive which I partioned as part of the as part of the Zorin upload following the options to retain windows. I can see both drives. I am not sure this relevant but the drive is named /dev/sda5/ however the boot executable code refers to /dev/sda3/
UEFI is enabled.

The installer will name the partitions as it needs, so you should be fine there.
For future reference (not related to the blank screen) if you do an install on another machine or reinstall on this one, it may be better to use the “Something Else” option to allow you most flexibility: Partition Scheme for Zorin (and removing Windows 10)
Let us know if the black screen thread helps you or not.

The black screen thread did not help I’m afraid. Clearly 2 partitions have been created but although I have the option at start up to select Windows (8) it just doesn’t execute properly. I chose the partition option as I still need to access Windows. How do I uninstall Zorin?
Thanks for your help.

Sorry to hear. I recommend disabling Secure Boot in your BIOS and trying. But if you still want to uninstall Zorin, you can use this:

Also, have you tried Boot Repair?

Hi Gareth,

When you presumably fix this issue – there’s a minor issue which is really annoying on the Windows side. The Clock ‘breaks’ on the Windows side. However, and don’t panic – there’s a very simple fix –

Trust me when I say if I can fix it – it’s simple.


1 Like

Thanks All for the advice. I really want to pursue this so will follow your recommendations. I looked at “something else” reinstall but didn’t understand the ‘select root’ instruction. Didn’t want to just guess which is the correct location.

I’ve disabled Secure Boot but no change. What I don’t get is that Grub reference for the Windows partIon is sda3 but it is shown in files as sda5. Doesn’t that cause a conflict or dead end pathway? As you can probably see I am not a coder.

If you are up to the task of reinstalling just to make things easier, that is a valid option. You should back up any personal files you have made on the Zorin OS, if any, before proceeding (Assuming you ever got it to boot at all).
When you move to reinstall, during the installation, you will come to the “install alongside” and the “Something else” options. In this case, you are best served by choosing “Something else.”
A Gparted session will open showing your current partitions.
If you like, you can post an image of what you see at that point here if you would like to verify what you are seeing assuming timely responses.
At this point, you probably are limited to only Four BOOTABLE partitions. So be sure to check that.
But, you should be able to identify the partition that you installed Zorin on previously. Click on it to select it, then click the (-) button down below to delete that partition. That area will now show in Gparted as Free Space. Select it again and click the (+) button to add that partition and it will now ask to Format It. You can select the size of the partition, Beginning of this space, choose the ext4 journaling file system and set Mount Point to (/).
Click (OK) and it will say it will continue and something like “at this point data will be overwritten, there is no going back” kind of thing. Select (OK) again.
It will proceed with the installation; just follow the prompts.

Thanks for that, if I can’t follow this guidance I shouldn’t be in charge of laptop. I’ll let you know how I get on.
Appreciate it.

Followed the guidance. All went well until start up and it would only boot straight to windows. Tried a reinstall a couple of times - same result. So have gone for the Big Bang option. Full Zorin install. Will I live to regret this? Time will tell!

[quote=“garethandalex, post:13, topic:1271”]Full Zorin install. Will I live to regret this? Time will tell!

I do not regret it. I do not even use WINE these days. :wink:

First we need to establish:

  1. Is this a Notebook (Laptop for those who use them incorrectly!) or Desktop?
  2. Does it have an SSD or a mechanical HDD (Hard Drive/s).

If SSD then the number of partitions is not going to be an issue. If an HDD then there will be an issue:

Proprietary Hardware Vendors that ship with that other OS usually create 4 Primary partitions
a. System partition at start of drive (hidden and marked as Primary)
b. C:/ where that other OS lives (Primary - has to be to be bootable)
c. System Restore Partition (hidden and marked as Primary partition)
d. System/Drivers Partition (hidden and marked as Primary

(When I state hidden it does not mean hidden from view entirely as Disk Management utility indicates)

In any event, but especially with Windows 10, room has to be made first using the Disk Management Utility - if there are 4 Primary partitions on the Hard Drive it is going to be impossible to install another OS unless you make the hard decision as to which Primary Partition to remove and then also shrink C:/ drive to allow Zorin to live alongside.

I would advise following this tutorial:

And before we forget, if an SSD, will need formatting to Ext2 file system as Ext3 and Ext4 are jounaling system - which is why you never got NTFS on those early mini netbooks with SSD’s - always FAT32 as not a journaling system.
One more thing if SSD you will need to setup TRIM as a CRON job - Windows does this automatically.

That’s how I’m handling this. I have a two year old Beelink Mini PC. Two years ago I paid like $160 for it. I’d be lucky to get $75 on eBay so I turned it into a LInux ‘toy’.

Linux actually rescued the Celeron from crawling. So there’s that.

Good luck.

1 Like

Switch completed. Just getting used to things. Seems straightforward enough. Wondering if I even need to download Wine?
Thanks for all the advice.

@garethandalex. If you do decide to include Wine then have a look at this item from AZorin.

For WINE, see 3b here: PlayOnLinux or Wine not working

And don’t forget to download the unofficial manual. :wink: