Windows file HDD only readable

So I guess this isn't Zorin-related per se but I couldn't find a solution in the web so I'll try it here:

I have two hard drives which I've been using under windows for over 5 years now. One is encrypted with bitlocker for personal files and one is just a drive for music and stuff.

So I'm now using Linux and can still use those drives without a problem. I just mount them and can access all the file, no problem. Even the bitlocker one works perfectly fine (and even faster than under windows). But for some reason the "normal" one just doesn't let me write files on it.
The encrypted one has no problems. Neither with drag&drop nor with the terminal. The "normal" one never let me use drag&drop but it worked in terminal with sudo mv.

Now it stopped working whatsoever, stating the file system is "read only". I'm not an expert in terminal yet, I don't know how permission control works with that but on the GUI of the drives it states "create and delete files" for anyone:

image

I thought of it maybe as an formatting thing. That the windows usage blocks some permissions maybe? Guess reformatting it and re-move the files onto it could help? But why's the bitlocker drive having no problems then? Seems kind of weird.
Anyways, I'm happy for ideas.

Normally, files in Windows are associated with the users that created them. If you log in to Windows as a different user and wish to open the files of a different user it states you don't have access, but asks if you want to make them accessible to you permanently so it changes the read write permissions. I suspect you need to edit the fstab entry of the drive to enable full access. I have never used fstab so can't help you. Perhaps @ Aravisian or members who have experience can help you with this.

Often NTFS Drives get locked by Windows because of the use of Hybrid Sleep and/or fast startup, you might wanna disable those in Windows by running powercfg /h in a CMD.

Also note: the Included driver (NTFS3) for NTFS partitions doesn't really do Read-Write, it's mostly suited for read-only operations.

You may want to install NTFS3G instead:

sudo apt install ntfs3g
 # or maybe it was ntfs3-g? or ntfs-3g? don't remember the exact name

Very rarely is it a permission issue.

I have the same issue, though that Windows drive has no issue running in any Zorin OS Core or Pro system, it just does not want to mount as writable on Zorin Lite, even adding rw and exec flags using gnome Disks when I mount it.

I'll try this when I can work on the system again.

1 Like

Hey

I've tried a few more times to get this NTFS back-up drive to be RW. but no success.

Disks_C

Am I missing something, as I already changed auto to ntfs-3g....

I got the drive unlocked, just plugged it into a windows machine and wrote a garbage file to it, shut down the system and put the drive back into its original system.

Thank you so much, i tried your steps on my Windows 8 drive and then got back to Zorin (on the same disk), the write protection was just gone