Windows freeze and overlap sometimes

Sometimes the windows freeze and overlap and I cannot minimize the window,this is so annoyong for me. Any fixes? I am new to zorinos 16 core but I have been using ubuntu 20.04 since last one year though I didnot encounter any of these issue in ubuntu. My pc specs:
Processor: Intel® Core™ i5-4200U CPU @ 1.60GHz × 4
Graphics: Intel® HD Graphics 4400 (HSW GT2)

1 Like

I might suggest disabling all extensions and testing with extensions disabled.
Zorin OS 16 is based on Ubuntu 20.04. Given that you did not experience this on your Intel system on Ubuntu 20.04 and that zorin OS comes with several Gnome-Extensions; it seems the likeliest culprit to me.

You can use Gnome Tweak tool to manage extensions

sudo apt install gnome-tweaks


It doesnot work I tried. I cant even minimize firefox and some other application windows and it keeps overlaping to one another. I am tired of this problem

Are you using fractional scaling or any other DPI scaling?

Fractional scaling was disabled by default

Did you double check the SHA256 checksum after you downloaded the Zorin OS 16 ISO file? I just want to make sure that the ISO wasn't corrupted in any way. As long as it passes, the ISO is fine.

Also, I am curious to know how Ubuntu 20.04 ran for you for the last year? I ask cause I looked at your system SPECS, 1.6GZ CPU is like tablet CPU speeds.

I tell you what, Zorin brother's are working on Zorin OS 16 LITE right now, which uses XFCE. When they release that, you could try that, more then likely will actually run a lot better on your system.

1 Like

I dont know what you talked about SHA256 checksum since I am not strong tech guy but it showed zero errors (while checking file on booting). And 1.6 GHz cpu is higher than system requirements of this OS i.e. 1GHz.As for ubuntu 20.04LTS it ran perfectly fine without any errors.

Yes, given your specs and stats in hte O.P., I cannot see any reason for you to experience this freezing.
Normally, I would think that aside from the dedicated intel graphics, there must be another graphics card involved.

Have you tested your RAM?

sudo apt install -y memtester

sudo memtester 100M 2

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.