Windows won't boot from GRUB

I'm a complete noob when it comes to this, I have no prior experience with Linux based systems. I just want to get Zorin up and running on my PC, with Windows remaining on my primary C drive.

I currently have Windows 10 installed on my C drive which is a 1TB Crucial P1 m.2 SSD. I also have a secondary drive,a 1TB Samsung 860 QVO SSD, which I just use for extra game storage. In preparation to install Linux, I shrunk the windows partition on my Samsung SSD (D Drive) to make room for Zorin.

As the title implies, after installing Zorin, I can't boot Windows from the GRUB menu. If I go into my motherboard UEFI and directly boot Windows using the standard Windows Bootloader (not Zorin / GRUB), it works fine! But I cannot get Windows to boot from the GRUB menu at all. It always says "starting automatic repair" then tries to diagnose itself but it doesn't do anything.

I've trouble a fair bit of trouble shooting that I can find regarding this issue, such as confirming both Zorin & Windows are in UEFI, disabling secure boot, fast boot & hibernation. I've also tried manually adding Windows bootloader to GRUB, but it just does the same thing - "automatic repair" and I can't get it to work.

I've also tried tools such as BootRepair, but this changes nothing. I'm unsure if it's truly a boot related issue, as like I said, booting Windows normally (w/o Zorin or GRUB) works fine! But again, I have no clue so I may be wrong!!

Here's a pastebin of the results.txt from BootInfoScript - Pastebin.com - Locked Paste Password is L5ZYRjxt5z

Any help is appreciated! Please ask for more info if needed. Thanks!!

Hello and welcome to the forum :slight_smile:

I remember I experienced something like that when I set Windows in a hibernation mode instead of complete shut down.
You might want to boot into Windows and verify that the hibernation mode is disabled.

1 Like

Hi FrenchPress, thanks for the prompt reply.

I’ve checked again and I definitely don’t have hibernation enabled. Secureboot and fastboot are also disabled.

I seem to be running out of options, I really just want to get Zorin up and running, Windows 10 is garbage! (Although I need to keep it for gaming)

1 Like

I wonder if the content of this thread will help you run ZorinOS on a second drive:

Can you please edit your grub file from terminal with:

sudo nano /etc/default/grub

Arrow key down to the bottom and paste in the following line:

GRUB_DISABLE_OS_PROBER=false

Press ctrl+x to exit, then tap the y key and then the enter key. The Terminal will revert to normal.
Now run

sudo update-grub