Wine and playonlinux: getting Paprika Recipe Manager to work

I am new on Zorin and Linux. I have purchased Zorin Pro 16.3 and while there are interesting opportunities there, I am very disappointed about running Windows applications. I have downloaded the Paprika Recipe Manager and tried to install it from the windows setup file, paprika.msi.

I get an error stating that I need NET Framework 4.6.2 minimum to make it work. I have searched this forum and others, and simply cannot resolve. When I reinstalled Wine then tried to install a later version of Framework, the system says that I already have a functioning version of Framework.

I'm starting to wonder if Wine and Playonlinux are only good for very old and obselete windows applications.

Any advice? Thank you.

I would actually suggest that we remove WINE as you had installed it and remove the residual files such as ~/.wine.
We can go step by step doing so.

Once done, we install a latest available version of WINE.
Then we attempt to install the necessary packages.
Again, going step-by-step.

Let's see if we can get it to work.

It is important to remember that WINE is not an emulator or an instance of running Windows. It is a compatibility layer that can allow Windows Apps to run on GnuLinux.
For general applications, it should work fine. But WINE is not for Windows System Applications.

Incidentally, .NET can be installed directly on Linux - indeed, I have it so installed due to other necessary dependencies for work.

Lastly, you are nowhere near out of options. If WINE is just not working out, you can run Windows OS with your preferred applications in a Virtual Environment instead of using WINE Compatibility layer.

Be fearless about picking the minds on this forum to help you get setup. We are here to help.

1 Like

I looked up the specs on this, does not like XP, only 7 or newer - which is okay! I have tons of apps that I use almost all the available versions haha XP the most with older games..

Did you happen to install Mono and Gecko with Wine?
Mono download ---> Index of /wine/wine-mono - Make sure to select your correct version! (I use 6.0.0 for Zorin)

Gecko download ---> Gecko - WineHQ Wiki - Same deal, just select your version of Wine! (I use wine-6.0-rc1 - wine-7.12 for Zorin)

I'm going to download the trial and see if I can get it working... Hold on to your butts! :joy:

1 Like

Okay - I got it installed, but doesn't like to run.. getting some:

'Unhandled Exception:
System.Runtime.Remoting.RemotingException: Channel is not securable while ensureSecurity is specified as true
at System.Runtime.Remoting.Channels.ChannelServices.RegisterChannel (System.Runtime.Remoting.Channels.IChannel chnl, System.Boolean ensureSecurity) [0x0002a] in <3d7a9349295c42b6abb3487b4473a6b8>:0
at 1[]. (System.String ) [0x00059] in <8b083b2c13df4db3b4bc5e49f759385f>:0 at 1[]. (System.String ) [0x00048] in <8b083b2c13df4db3b4bc5e49f759385f>:0
at Paprika.Windows.App.Main () [0x0000a] in <8b083b2c13df4db3b4bc5e49f759385f>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.Runtime.Remoting.RemotingException: Channel is not securable while ensureSecurity is specified as true
at System.Runtime.Remoting.Channels.ChannelServices.RegisterChannel (System.Runtime.Remoting.Channels.IChannel chnl, System.Boolean ensureSecurity) [0x0002a] in <3d7a9349295c42b6abb3487b4473a6b8>:0
at 1[]. (System.String ) [0x00059] in <8b083b2c13df4db3b4bc5e49f759385f>:0 at 1[]. (System.String ) [0x00048] in <8b083b2c13df4db3b4bc5e49f759385f>:0

I had to use 'wine msiexec /i installer.msi' to install. My machine and user are named 'pwned' to save confusion lol

I'm trying to figure out the remoting channels stuff now, just trying to get it to run. I have dotnet-7.0 installed, might remove that and try 6 - though may not have any change.. Let's see!

(update) Nope.. 6 didn't help...

Okay, those errors were probably my fault - chasing .Net versions now. Have 4.0 installed, gave errors for 4.6.1 - installed 4.8.1, still says 4.6.1 is needed, though included with 4.8.1 lol I'm chasing versions to see what works..

(update update)

This is rather annoying.. I have installed 4.0, as the installer asks for - then asks for 4.6.1.. then I uninstall 4.0, then install 4.8.1 - which includes 4 and 4.6.1, still not.. says I need 4.0 :melting_face:


Which is installed...


.. I have to be doing something wrong..

1 Like

Thank you so much for trying and sharing your experience. I tried multiple things, cannot elaborate as I am new and simply following discusison boards conversation addressing this topic in general. If you succeed, please share.
Again, appreciated.

@LucLeves , would you like to try setting it up as per my post above?

I would love to, but as a linux newbie, the instructions are not detailed enough. Sorry. I'm willing to do this. Thanks.

Not a problem. As I said, let's walk through the process, step by step. I will be here to explain any terminal commands.
I need to leave the computer for a little while and run some errands.
While I am away can you answer the following:
How did you install WINE? From an online guide? Or did you install zorin-windows-app-support? Did you install in terminal or with the Software Store?

1 Like

Thanks. Initially, i installed it from the Software center. It didn't work. Then, i went to an Ubuntu forum, deleted the unstalled wine to install wine version 8.0. Didn't work. I still have wine 8.0 installed.

Also, tried to install with playwithlinux which was outbot of the box with Zorin. Didn't work. I gave up there.

Absolutely no worries!

I searched around on the WineHQ site - version 3.2.4 is being tagged as 'gold' status on their support side. I'm downloading that version now to see what happens. Trial, so not sure if you're a paid user or not, heh.

All I have right now is Gecko, Mono, and Wine 6.0.3 - got rid of the other 4.x.x versions as they aren't seeming to be of any help lol got further with just Mono than with .Net installs.

I'll just update what happens with 3.2.4..

1 Like

I did get V1 on their site, it is available to download. It's under the regular download buttons in italics.

But, now I can't get past:

0104:err:ntdll:RtlpWaitForCriticalSection section 67C57100 "dlls/mscoree/metahost.c: runtime_list_cs" wait timed out in thread 0104, blocked by 0024, retrying (60 sec) <- with V1 Paprika.

I can't get past another issue like this with an application I use for an OBDII device; will not work in Wine.. So, I'm bound to Windows for that one!

I did try nuking the Wine install I have, reset winecfg, multiple .Net versions and mono, different Win versions through winecfg; unless I'm doing something wrong (and I probably am), I'm out of ideas..

I'll take a seat for now lol will follow along - very interesting, this app is :thinking:

You keep saying you are so new, but it really sounds like you have been doing well for yourself.
I think we can skip the step by step stuff- since you already added the repository and key and installed Wine 8. You can double check in your terminal with

wine --version

I see PlumpKibbles was actively performing the install in order to test and also had no luck.
I will try replicating these results since I do have some time in experiencing tricky installs. But if I end up on the same road as PlumpKibbles, I may suggest the option of either running Dual Boot with Windows (least preferred option) or running Windows OS in a Virtual Environment.

If you have a copy of Windows at your disposal right away, you could install Boxes

sudo apt install gnome-boxes

Insert your Windows Media, launch Boxes and select "New" and navigate the file manager popover to your Windows Media.

1 Like

Hi Aravisian, that is nice of you. I played with Linux over 20 years ago, and it is coming back a bit. I read forums and try to investigate on my own. I have identified another resource for my recipies, so perhaps, we could drop this.

My worry though is that I may have another Windows program to install eventually, and may not work.

What I love about Zorin OS Pro and Linux in general is the stability and reliability. Also, I have to move on from Windows that is buggy and frustrating at times. However, I'm realizing that Linux comes with their own set of frustrations that are very different from Windows.

I've toyed about going to MacOS, but my brain does not work like their environment, so I will be frustrated again. No perfect world.

I will give Zorin OS a real solid try, because I can still do over 85% of what I need to do on a computer with it, that is not nothing.

You guys are amazing. Thank you.


I installed WINE with high expectations when I moved from Windows to Zorin OS.

A lot of things happened. And time passed.

Now, I never install WINE; nor use a VM for it. I no longer have any applications that are Windows only, in large part to the learning curve.
Some had native Linux apps to replace the Windows ones.

Some could be modified to run on Linux without needing WINE at all.
I notice many other users also comment that as time passes, our need for WINE or Windows-only apps generally decrease. And many times, we cling to our Windows apps because they are already familiar and we already traveled through their learning curves.

1 Like

Wouldn't suggest a new one, no experience with them. But, an older i7 MB Air wouldn't be bad! Been seeing those on eBay ~$250-ish, 1TB SSD / 16GB RAM. Thinking about grabbing one when I can - just to run Linux. :grin: Have heard good things about using older MB's with Linux and success.

Just sayin!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.