Wine DX11 Not Functioning After Upgrading GPU

I recently upgraded the graphics card on my system running ZorinOS, while it seems the new card is running and recognized. When trying to load DX11 wine games on Steam I get the following error:

Failed to initialize graphics.
Make sure you have DirectX 11 installed, have up to date
drivers for your graphics card and have not disabled
3D acceleration in display settings.
InitializeEngineGraphics failed

System information:
Old GPU was a nvidia
OS: ZorinOS 16.2
GPU: AMD ATI 0d:00.0 Device 73ff (that's according to neofetch, it's a RX6600XT)
CPU: AMD Ryzen 5 5600X (12) @ 3.700GHz

Tested games:
Yandere Simluator (lutris)
Overwatch 2 (lutris) (Error here is: "No compatible graphics hardware was found (0xE00701B0))
Slime Rancher 2 (Steam, adding "PROTON_USE_WINED3D=1 %command%" allows game to launch but graphics are bugged out.)

How can I fix or further debug this issue?

Gday @aflyingpumpkin ,

Could you please show the results here for this:

sudo lshw -C display

As you had a Nvidia card, i'd also open "Software & updates" goto the "Additional drivers" TAB If possible unselect/remove the Nvidia driver, If you have a driver in there that suits your card , then select it, a generic choice would be a "X.Org" driver.
You could then run a full update/upgrade.
See if this helps.

Then retry directX, ( i don't use wine/play on linux, but i would assume directX would be maintained/with-in by one of the above?)
Someone that know about wine/etc will help further when their available.

1 Like

In Steam Settings, also try disabling Vulkan and testing after a reboot.

Another option in Steam Settings is to check if you are launching with OpenGL.

1 Like

@Ocka sudo lshw -C display:

       description: VGA compatible controller
       product: Advanced Micro Devices, Inc. [AMD/ATI]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:0d:00.0
       version: c1
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: irq:76 memory:d0000000-dfffffff memory:e0000000-e01fffff ioport:f000(size=256) memory:fc900000-fc9fffff memory:fca00000-fca1ffff

No drivers appear in additional driver (bar a probably unrelated realtek one.)

@Aravisian I could not find the mentioned options in the settings menu or after looking them up. The closest I could find was disabling Vulkan shader pre-caching (no effect,) and using the -force-opengl launch flag in game-specific settings (on slime rancher 2 using the flag changed the error to: InitializeEngineGraphics failed)

1 Like

I looked into this and apparently, by default - Vulkan is not enabled using Steam on Linux -a user must enable it manually. So that clears that up.

Correct on this one. But it seems that did not help you any...

EDIT: Searching I came across:
PROTON_USE_WINED3D=1 %command%

This, too, must be added to the individual games launch command...

This is done from Steam >Library > "Game Title" (right click > choose Properties) > General tab > Advanced... launch... modifications (the ellipses are due to me not exactly remembering the full sentence displayed on that option, but it gives you enough of an idea to quickly spot what I am referring to...)

As per my original post:

Slime Rancher 2 (Steam, adding "PROTON_USE_WINED3D=1 %command%" allows game to launch but graphics are bugged out.)

Thanks for the suggestion though!

Ah.. sorry. I even remember seeing that now, but by that point in the thread, I had forgotten.

I will go drink a glass of bleach.