Wine installation error

I recently switch from windows 10 to zorin os
and i was trying to install wine but an error occurs
when i type

sudo apt install --install-recommends winehq-stable

the result is

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
winehq-stable : Depends: wine-stable (= 7.0.0.0~focal-1)
E: Unable to correct problems, you have held broken packages.

Have you first tried installing Zorin Windows App Support from Software Store, which includes Wine and PlayonLinux?
See this:

1 Like

I search windows app support it in software store but it was not their.
Then I directly click on a .exe file to install windows support app but it also give a error.
Then I tried to install wine from software store it give the unmeet dependency error.
At last I tried to install wine from terminal and it gives the error shown above.

Did you just look for it in Software Store or did you do a Search for "Windows App Support"? It should definitely be listed from a Search.

I search for "windows app support" in software store.
Also I tried to install windows app support form terminal but it was showing error

Open Software Updater and check that it is pointing to "Main Server" and not a regional server.

it is on regional server but now i change it to main server

I have just had a search for Windows App Support in Software Store and you are correct, it has gone missing. I will flag this to the devs @AZorin @zorink , as ZorinOS is intended for Windows refugees.

2 Likes

We have definitely been struggling with this one, lately.
I also cannot install Wine, currently. Fortunately, I neither need, want or use Wine.
But testing this for other users now yields the same result that they get - on the Main Server.
I can only assume that a repo package dependency is either broken or missing.

2 Likes

is there any way to fix it.
reinstalling zorin os will help?

In this case, I doubt reinstalling Zorin OS will change this.
However, there are some things you can try just to be sure:
Open Software & Updates and read the sources list carefully and ensure that you Do Not have any Wine Repositories added that should not be there (Like Groovy or Impish). Ensure you have ONLY the Focal Wine Repository. Remove any others like Groovy or Impish if they are present.

Change your /etc/apt/sources.list to Main Server Manually.

I would go with GUI on this, just to make your life easier.

sudo -i

Because you use Zorin OS Pro Lite:

thunar

(Pro or Core users should enter in nautilus instead.)

Now, tap the up arrow key on the toolbar two times to got to the top of the tree in root. Then double click /etc, then /apt and then right click the sources.list file and open it with your Text Editor of choice.
Ignore any line with a (#) at the front.
Look for a line like deb http://archive.ubuntu.com/ubuntu focal main restricted that has a Regional Server noting it and remove that two letter regional indicator to make the line look exactly like the one I pasted above.
Repeat for:
deb http://us.archive.ubuntu.com/ubuntu/ focal-updates main restricted
deb http://archive.ubuntu.com/ubuntu focal universe
deb http://us.archive.ubuntu.com/ubuntu/ focal-updates universe
deb http://archive.ubuntu.com/ubuntu focal multiverse
deb http://us.archive.ubuntu.com/ubuntu/ focal-updates multiverse
deb http://us.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu focal-security main restricted
deb http://security.ubuntu.com/ubuntu focal-security universe
deb http://security.ubuntu.com/ubuntu focal-security multiverse
deb http://archive.ubuntu.com/ubuntu focal-updates restricted multiverse universe main
deb http://archive.ubuntu.com/ubuntu focal-backports restricted multiverse universe main

Once done, Save the file
Close it out, close out Thunar.
In the terminal, run sudo apt update && sudo apt upgrade

Try installing Wine...

1 Like

You could try to install from terminal.
sudo apt install zorin-windows-app-support
If you get errors about a broken wine install or similar
try
sudo apt remove *wine*
sudo apt update && sudo apt upgrade
sudo apt install zorin-windows-app-support

@seanhinkley I think the OP already tried installing via terminal and failed.

1 Like

@zabadabadoo I missed that :slight_smile:

might still help to remove any wine packages that may have installed as a broken package can do funky things

2 Likes

I have managed to find Windows App Support on the Software Store by searching using the search term "Zorin" (without the quotes).

I tried "Windows App Support" as listed, also "Zorin Windows App Support" without success.

Amazingly illogical. :confounded:

I wonder if this is a Software Store error that the devs @AZorin @zorink can fix, as it sure makes life difficult for newbies wishing to install the Zorin's preferred Wine solution.