Wine reinstalled but still cannot "open" files from Linux partition

I know it's a service/other I disabled or uninstalled... but cannot remember what!
The problem is that Wine apps CAN READ (can see) but CANNOT OPEN files that are in the Linux drive.
If I place the same file in a USB drive and open it, no problem.
For example in IrfanView the message I get is: "can't read file header...unknown file format, empty/damaged file or file not found!".

Does this help?:

I have all the default drives (I believe as before Wine was reinstalled):

C = Drive C
Z = / = (root of Linux)
and others

But still same error. Pretty sure it's a service/something I disabled that will not let Wine "open" Linux files/drives (I can see the files though)... samba, or other?

You could try removing your wine config - just delete the .wine folder in /home. That will remove all your apps too though - just rerun winecfg or the wine configuration app. But, as stated, this will remove all wine apps.. not sure what all you have going with wine.

No "wine" folder under /home but did find a "Play on linux" folder that had the "irfanview" folder (the only Win app I have) and I deleted that.
Irfanview still runs, so I didn't get the right folder...

It's a hidden folder, if you're in file explorer hit Ctrl+H to show / hide hidden files - it's labeled .wine


That worked! Deleted .wine (was recreated by Wine) reinstalled Irfanview and now image files can be read!

1 Like

Noice! :sunglasses:

Another good one, if apps hang - wineserver -k kills the Wine server, then reopening may work out. I've had to do that a lot with games in the past.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.