Wired connection stopped working

I have a PC with dual boot. I was switching back and forth today between Win10 and Zorin OS 16 and after a restart the wired connection stopped working on Zorin OS. It works fine on Win10...
It says connection failed...

Maybe there was an automated updated which jinxed it or the ISP pushed some smart update onto the router? Also i see weird issues with this PC, maybe the motherboard starts to play up..

I'm still very lame regarding network diag on linux, i found this article and tried some commands: Troubleshooting Ubuntu network connectivity | Ubuntu Server | HostingUltraso.com

According to the article the last command results means that "DHCP server is not accessible or not assigning an IP address to this client".

Can you pls give some tips, magic linux commands to troubleshoot properly this phenomena?

I would start with the Simplist solution, restart the router and let it flush it's cache, it may have just become confused from 2 clients same Mac addr different host names.

1 Like

Thanks, but didnt help.

Just to see if it was a kernel update that has affected it. Have you tried booting a previous linux kernel, selected from Zorin Additional Options at grub menu?