Wireless USB Stick

I bought a wireless usb stick for my computer that supports linux.

On windows it was just plug and play and it worked.

Here on Zorin I do not know how I can install drivers or find the wlan stick.

1 Like

Did the wifi adapter come with any linux drivers e.g. on a mini CD or available on their website?
What wireless chipset does it use?

1 Like

First of all refer this post for explaining your issue briefly, with some additional information. We are unable to provide help if we even don't know the type of wireless usb you are using :slightly_frowning_face: (please provide the amazon link for the stick)

We can help resolve the problem.
Can you find some information about product Model version or something else what help us to find drivers and help you with installation them?

1 Like

There is not a lot of information about it.

1300Mbps (2.4G/5G) 11ac Wireless Lan Card

It seems like a Realtek one.

Here is an amazon link of the product: https://amzn.eu/d/4Pg1UdJ

I was able to pull some information on my windows environment:
Realtek 8812BU Wireless LAN 802.11ac USB NIC

I am completely new and dont want to type in any command from google :slight_smile: (hope thats understandable)

1 Like

wireless - How do I install drivers for Realtek RTL8812BU? - Ask Ubuntu Here is instruction to your model.
Do you can forward with that instruction on this side guide?

1 Like

No not really. Tried but was not successful

sudo modprobe 88x2bu
modprobe: FATAL: Module 88x2bu not found in directory /lib/modules/5.15.0-48-generic

1 Like

There is another thread on the forum that discusses a similar Realtek RTL8812xx installation. Maybe something there will help, by substituting RTL8812BU for RTL8812AU.

1 Like

You might try this driver, including using DKMS to ensure it rolls with the kernel:

To install:

Ensure essentials are install first:

sudo apt update && sudo apt install -y dkms git bc

Use git to pull the package:

git clone https://github.com/fastoe/RTL8812BU.git

Change Directory (cd command) into the retrieved directory:

cd RTL8812BU

Use sed to set DKMS

VER=$(sed -n 's/\PACKAGE_VERSION="(.*)"/\1/p' dkms.conf)

Install. This is a complicated installation... Because Realtek likes to get complicated with their driver versions...:

sudo rsync -rvhP ./ /usr/src/rtl88x2bu-${VER}

sudo dkms add -m rtl88x2bu -v ${VER}

sudo dkms build -m rtl88x2bu -v ${VER}

sudo dkms install -m rtl88x2bu -v ${VER}

sudo modprobe 88x2bu

If you get any errors, please stop and relay what error you got. The above is involved... most installations on Linux are nowhere near so involved. But RealTek does things with their drivers in a funny way. I mean, why do they have a Million different drivers out there? For what is essentially the same product? They make a change to existing drivers for one reason or another, tag a new version I.D. on it, then set the hardware to not work correctly unless it uses that tag. Then it is up to everyone else to try to keep up with all those different tags. Even Nvidia does not do this.
Reboot your system if the above commands run through without trouble and test your wifi...


@Aravisian maybe that help?

1 Like

It might - I do not know the difference, if really there is any, between 8812bu and 8822bu.
The instructions in your link say to:

sudo apt install rtl8822bu-dkms

1 Like

Do I have to copy and paste it or how am I supposed to find the package version?

Yes, the command specifies that the installer will adhere to the version. You do not need to seek it out.

1 Like

Thats what I got after entering it
sed: -e expression #1, char 30: invalid reference \1 on s' command's RHS`

Sorry... forum format strikes again...

VER=$(sed -n 's/\PACKAGE_VERSION="\(.*\)"/\1/p' dkms.conf)
1 Like

sudo dkms install -m rtl88x2bu -v ${VER}

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area...
make -j4 KERNELRELEASE=5.15.0-48-generic KVER=5.15.0-48-generic src=/usr/src/rtl88x2bu-5.6.1.......(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.15.0-48-generic (x86_64)
Consult /var/lib/dkms/rtl88x2bu/5.6.1/build/make.log for more information.

testzorin:~/RTL8812BU$ sudo modprobe 88x2bu

modprobe: FATAL: Module 88x2bu not found in directory /lib/modules/5.15.0-48-generic

Great. The 5.15 kernel lacks the module.
Is this an Old piece of hardware? I wouldn't think so...
But who knows what people will sell and make claims about...

You might try

sudo apt install linux-modules-extra-5.15.0-48-generic

Then repeat the above.
If that fails, then try the suggestion made by @Bourne

sudo apt install rtl8822bu-dkms

1 Like

Unable to locate package :confused:

Tried doing that... May try tomorrow since I am trying the whole to get it work :frowning:

Why is it that on windows its just plug & play and on linux its a nightmare ..

Because... it isn't.

Do a search on Windows OS users trying to find, fix or upgrade drivers some time and you will easily see what a nightmare it truly is.
You may personally have only ever experienced Plug N Play on Windows.
I have only ever experienced working Plug N Play on Zorin OS... In fact, I solve far far more problems that other people find and run into than I ever encounter on my own.

But... it is true that Windows gets better hardware support since Microsoft dominates 90% of the market...

1 Like