WLAN BrosTrend AC1200

If you have been following the previous tread from me I was really struggling with getting the WLAN USB stick to work. I purchased a new one from the brand "BrosTrend".

Installation was very easy and it worked out pretty well. (Installation of drivers took 2 minutes). I just had to copy and paste a command.

The problem is that I tried the stick on the same machine with windows and had about 100mbps more. Is there any linux limitation causing this?

I did not change any parameter except doing the benchmark on ZorinOS not on Windows 10. I did redo the benchmark many times and even checked what my router is getting from the service provider. I even used the same browser for the benchmark.

Are you currently set on IPv4 or IPv6?

Ehm... I dont know.. I guess ipv4

You should be able to check in your network manager settings.
I am not using Core (I use Lite) and I cannot recall off the top of my head the full navigation on Gnome...

I have had a lot of connection issues with a BrosTrend USB WiFi Adaptor (not the same model). No matter if Zorin, Manjaro or Fedora. It always kept disconnecting. Same machine under Window$: running smoothly.

On my laptop i had success with disabling the wifi setting “Make available to other users” and saw a significant boost.

It could very well be the drivers, many vendors have optimized windows drivers as its a more popular OS and ms has Driver dev kits. However, many newer wifi sticks have trouble with older routers specifically if the stick is N or AC, and the router only supports <G

If your router doesn't support N but the wifi adapter does try

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1
If that works you can make it permanent in the conf file, if it doesn't work Reboot and the modes will be reset

1 Like

I actually do not find any settings for that. Just that IPv4 and IPv6 is enabled.

Ok I will see and try if that will happen.

rmmod: ERROR: Module iwlwifi is not currently loaded

ok your drivers might not use iwlwifi, thats fine did unchecking make available to others make a difference?

I looked up the WiFi adapter, and from the description it seems like they legitimately try to support Linux too.

In my experience with WiFi adapters however, they can be very finicky when it comes to different kernel versions.

While it won’t directly offer you a solution, it could be interesting to boot a live session of the latest Ubuntu for example and see if there is a performance difference. Note: The WiFi adapter supports up to Kernel version 5.18 according to specifications.

I tried but looked like performance got worse so I changed it again.

Thats something I might try if I can get it to work with a live system. It was not supported by default and I had to use the terminal to make it work

try this---- GitHub - morrownr/8812au-20210629: Linux Driver for USB WiFi Adapters that are based on the RTL8812AU Chipset - v5.13.6

Will this improve speed?