WPS Office will not install?

So much talk on here about WPS Office so I thought I would see what's it's about. I downloaded the deb install file, right clicked on "Open with Linux install application" and it never installs. The time clock just goes on and on and on and on . . . .
I tried several times after a "sudo apt update" and no dice. Anyone have any ideas?
I

For me, it is working.
I use Gdebi installer.

Personally I prefer Free Office from Softmaker.
https://www.freeoffice.com/en/

Here is how to install WPS Office:

Or as French Press has stated using Gdebi Package Installer if you need a GUI (Graphical User Interface). Install via Terminal:

sudo apt-get install gdebi

or via Synaptic Package Manager available in Software Channel where you search for gdebi; you will need to install gdebi and gdebi-gtk.
In this particular instance the terminal method is more straightforward than using Synaptic.

1 Like

Thanks FrenchPress - Gdebi worked fine, thanks!

2 Likes

Oh, I'm using FreeOffice now and love it, just wanted to see WPS. Thanks . . .

Just to let everyone know, I tried WPS Office for a few hours, uninstalled and went back to FreeOffice. So much easier . . . I really did try :grin:

2 Likes

Yup. That is the right attitude :slight_smile:
When it comes to the final judgement, you are the best judge of your own settings and use cases :trophy:

1 Like

The only downside I could find with WPS is the lack of language support for my language. I'm talking about spellchecker :stuck_out_tongue:

1 Like