Wrapping up fresh install of Zorin; requesting help with a few "misc" things

First, thanks to whoever replies here. I am wrapping up a fresh (and final) install of Zorin OS 17 Pro on my PC, and need to ask about three issues before I can consider this installation truly "complete." See below, please ...

  1. For the built-in screen recording, when I start to record video, there is nothing I see that will enable me to stop recording. No visual input as to what key combination I could press to stop, nor is there any "stop" button I can press anywhere on the screen. I have to log off to just get my PC to stop recording video. Is this a bug? Or is it my PC? (Doubt it, but you never know.) The image capture works fine, though. Clear as a bell as to how to use it.

  2. Previously, in another forum message, I'd asked how to uninstall LibreOffice. Someone provided a solution, which worked great. However, in what is a small annoyance, the "New Document" menu entry in the desktop context menu still retains LibreOffice entries. How do I get rid of these? For now, I have left LibreOffice on my new Zorin OS install, and am willing to live with it if I cannot easily get rid of the context menu entries.

  3. For whatever reason, my screen goes dark after 5 minutes of gaming (without touching the mouse) on my gamepad. This is directly correlative with the power settings (which are set to turn off the monitor after 5 minutes of inactivity). Why aren't the power settings respecting my other activities on the computer while I don't use the mouse? What can I do to fix this? To that end, I've heard of this program called "Caffeine." Do I install that? Or is there another way to resolve this problem without having to install an app just to restore the intended functionality?

Again, thank you to anyone who responds. Happy I bought Zorin OS Pro.

Just need to take care of these last few remaining items ...

Screen Recorder:

When recording is in progress, there is an icon on the top bar. Click it to stop recording.
screen-recorder

Context Menu:
Delete unwanted items from ~/Templates

Screen Blank:
I don't see what you describe. Sorry.

  1. Use GPU Recorder instead, the builtin recorder is rubbish.

  2. Look in Template folder to delete unwanted templates

  3. So do mine also, I have just noticed :smiley:

My responses:

  • Thunderation! Didn't know about the templates folder. Wow. Thanks.

  • I didn't see any icon or anything. I will try again and report back, though.

  • OK, so how do we resolve the screen thing? How's that fixable? Anyone?

Update: Double-checked and I do NOT see any way to stop recording.

Check if the app is actually recording. There should be a .webm file saved in ~/Screencasts.

It is recording, yes. I have to log off, then sign back on just to regain control of the desktop. The screencasts are successfully saved in the "videos" folder. So ... yeah.

I am using desktop layout 4 (gnome). If you're not, that might account for it.

Also, it's reported that this default screen recorder does not record audio. For that reason, you may want something else:

Possibilities:

GPU Recorder recommended in a previous post. (I haven't used this myself)

Simple Screen Recorder. I have only used this app. But, it only works with X11 session, not Wayland. If you are interested, this package is in the Software Store, as:

"SimpleScreenRecorder (UNOFFICIAL)"

Be sure to select the Zorin OS package, not the snap package.

You can also install from terminal:

sudo apt install simplescreenrecorder

Thanks - I think I'll stay with Peek. It works, so why not? Thanks again.

P.S.: But it'd be nice to have the built-in option work "right." Too bad it doesn't.

I would recommend Caffeine, yes. It is a simple solution to a pesky problem.

It actually doesn't work. What I mean by not "work," I mean that I can't tell if the program is running or not. There are no icons to be seen (like the coffee cup) that tell me that it's activated, at least. No nothing. Unfortunate ...

When I tried Caffeine, it lacked an icon. Like TLP, it just runs in the background. Have you tested whether the computer goes to sleep?

Hi, Aravisian. No. Once I saw that nothing was happening, I didn't pursue it any further on Zorin. I did try installing Caffeine on a live USB session of Linux Mint, and it worked perfectly. The icon came up fine in the taskbar ("panel" on Mint).

I would recommend trying it out. Caffeine is harmless and can be removed if it is not working out.
I never had a panel icon for it; I guess that is just a variable - with the icon you can disable or enable it at need whereas on my system, it just stayed enabled.

1 Like

I can also recommend Caffeine. It had a panel Icon the first time I launched it. Since then it runs in the background without any notices and prevents the screen from going to sleep. I probably will never understand why this isnt a feature out of the box but its a good workaround for now.

1 Like

Weird. Why did @Wurstspaghetti have an icon, but I didn't? I'll try again later.

I noticed just now that I only have an icon if I start the "caffeine indicator". Otherwise it runs in the background without an icon. I probably have remembered wrong how it behaved when I installed it. Like I said it runs now without an icon and I prefer it that way.

1 Like

I did try starting the "caffeine indicator." Nothing. As I said, weird.

It worked beautifully on Linux Mint, but nothing came up in Zorin OS.

:cry:

Hello,
I was facing the same problem. solution to it is that you make 'right box' visible from taskbar's position settings.

one which makes your keyboard layout icon be seen.

1 Like