Write permission denied to mounted directory

Hi all,
New to Zorin and also first time using dual boot system. I’ve looked through many articles on this but can’t find a solution.
I have mounted my windows NTFS partitions to /media/$user/foo using the Disks utility and everything works fine. Auto mounts on startup and all. I even have set up the read-write permissions (with chown and chmod) so I can copy files to the mounted directory.
But when I try to save a file from a software (like saving a file from OnlyOffice or other software), permission denied to the mounted directory. What am I doing wrong?

Can you right click on the partitions and/or folders of interest and select Properties and then the Permissions tab and confirm you have the permissions? Should be Create and Delete files. See if it works when you change all permissions to that.

All of them are ‘create and delete files’.

I don’t know what to say. I don’t have OnlyOffice, so I tried the same exercise using WinRAR (with Wine) since my Linux programs aren’t showing that issue. No problem there too - I could create and extract archives on a mounted drive.
You’re able to access your Windows partition files fine, like in Nautilus, correct? Only the applications have problems, right?

I just tried saving files to the mounted directory from LibreOffice, Foxit reader, Brave browser etc and they have no problem. OnlyOffice, Notepad++, qbittorrent can’t access the mounted directory from what I’ve tested so far. So it’s not a mounting problem. :frowning:

Found some results online saying fast startup/boot should be disabled. Have a look here: partitioning - Can't write on ntfs partition shared with Windows 10 - Ask Ubuntu

Are those all run from Wine?
If so, do you mind installing one of the applications using PlayOnLinux and seeing if running from POL allows access to the partition?

Found the solution! I went back to the Software Store and looked at the troubling software. I saw the permissions button next to the Launch and Remove buttons. Then I saw that I had to enable the ‘Read/write files on removable storage devices’. When I did that, I could access the mount directory without a problem. I can see it’s only these couple of software that gave me the trouble that has the permissions button, and not the others. Does that mean they run on Wine? (I knew that Notepad++ was run on Wine but couldn’t find anywhere if qbittorrent or OnlyOffice etc was so).
Thank you @carmar for your assistance!

Glad it’s sorted out and from what you describe it’s not a Wine issue. I see qbittorrent on Synaptic so most likely you have the Linux version.
I don’t know about OnlyOffice - you can check using Synaptic or dpkg --get-selections if you have it. If it is a Snap package, you will see it when you run snap list .

Yeah, I just saw that the ones I mentioned are all snap packages. Since I’m not too savvy about what exactly that means, I’m going to look into that a bit. Cheers!

-chuckle-

Explosion in…
three
two
one…

1 Like

BOOM!
As soon as you said they were Snaps, I thought, here we are again. Application under house arrest.

1 Like

Sorry I’m an absolute newbie to this. Is this being discussed every other day and snaps are discouraged?

@randyB Sorry, but yes we have seen several situations reported on here which are ultimately tracked down to the app being installed as a Snap. Unfortunately, that is likely to become more commonplace if Software Store (Ubuntu) places Snaps higher in the pecking order than normal apt installs.
As a newbie, when you go “shopping” for apps in the Software Store, have a look at the source details to see if it is a Snap or not. If you enter the app name into Search within the Software Store, you can usually find the same app, though maybe a slightly older version, listed which is not a Snap. Maybe also indicated by more stars given by users in feedback.
The other method is to install Synaptic Package Manager, which can be found in Software Store, then use that to install apps.

2 Likes

We fall into an opinion trap.
“Snap Installs” are sandboxed installations that Canonical introduced as a supposedly easier way to install applications. There are several problems with Snaps.
First and Foremost - they are sneaky. Canonical pledged at the outset that Snap Installs would never replace normal installations, then broke that pledge and replaced regular installations with Snaps. For many, that felt like a Pure Microsoft move.
Snap Installs have replaced regular installations in some very sneaky ways, often without warning the user that Snapd is being used.

Snapd has also been shown to carry multiple security holes. This is partly due to the way they are sandboxed, rather than in a repository with a key. Snap installations come with all dependencies (Which means: BLOAT) whether you need them or not, they are included, per installation. This can include other things, however and being sandboxed, they are not easily identifiable.
Snap Installations have been prone to cause other issues on systems (conflict) or have flaws themselves - and this makes Troubleshooting here more difficult when the snap was snuck in and the forum member does not know that it was a Snap Install, causing us all a wild goosechase.
Snap Installations do not use system themes or icon sets, which can confuse the user, as applications that should be recognizable are suddenly unfamiliar and unrecognizable as to the various buttons and functions looking totally different from the rest of the system, or from its own copy /sibling app that was NOT a Snap Install.

Zorin OS does not discourage snaps.
Canonical is desperate to encourage snaps- to the point of concerning behavior.
But as a personal opinion of some of us in the Linux Crowd- they are Highly discouraged. I, for one, would love nothing more than that our voices be heard and M$ stylized Canonical recognizes that they do not get to break their word, do not get to Force products and that User Control is what FOSS is about, Not Canonical Control.

2 Likes

hey dude i created a partition in zorin os lite but i cant create or move any folders in that partition so please give some solution

Try changing ownership and permissions of the partition: