Xbox One Controller Not Staying Connected

Hey internet!

So here's the story...

Upgraded wife's computer for Christmas and windows didn't work initially, tried Zorin OS to help troubleshoot and she ended up staying with it because it was "just working" at the time. Well later we try to connect her Xbox One Controller over Bluetooth and the dongle, and neither are working. I have abandoned the dongle purely because it seems to be only kinda functional with a github project in the works right now.

The issue:

When I attempt to connect the controller, the initial pairing does "work", I get a confirmation vibration from the controller. However, the light on the controller continues to blink, and a few seconds after the initial connection the bluetooth settings will blink on and off for the specific controller. After all of this, the controller disconnects and is unable to reconnect unless I re-pair the device.

When I run xboxdrv, the below is the output. I have run this same command while bluetooth settings show "connected" and I get the same result. The only time the blinking on the controller goes away is when I connect the controller via USB C, however, I still get the below error when running xboxdrv. I have found this forum post and I watched the video, which I followed and did not help the situation. Xbox series x controller bluetooth

I have run the update command on the system a few times to ensure I'm as updated as can be. Really need the help on this because I would love it if I can keep my wife on Linux. It would be an awesome win. Thank you!

xboxdrv 0.8.8 - http://pingus.seul.org/~grumbel/xboxdrv/
Copyright © 2008-2011 Ingo Ruhnke grumbel@gmail.com
Licensed under GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under certain
conditions; see the file COPYING for details.
-- [ ERROR ] ------------------------------------------------------
No Xbox or Xbox360 controller found

Here is a neofetch of the build:

Zorin OS 16.2 x86_64
Host: X570 Steel Legend WiFi ax
Kernel: 5.15.0-57-generic
Uptime: 14 mins
Packages: 1891 (dpkg), 22 (flatpak)
Shell: bash 5.0.17
Resolution: 3840x2160
DE: GNOME
WM: Mutter
WM Theme: ZorinGrey-Dark
Theme: ZorinGrey-Dark [GTK2/3]
Icons: ZorinGrey-Dark [GTK2/3]
Terminal: gnome-terminal
CPU: AMD Ryzen 5 5600X (12) @ 3.700G
GPU: AMD ATI 0e:00.0 Device 73ff
Memory: 15919MiB

To solve your problem:

  1. Install sysfsutils
sudo apt install sysfsutils
  1. Edit /etc/sysfs.conf (as admin), add this line at the end of the file:
/module/bluetooth/parameters/disable_ertm=1
  1. Save changes and restart
1 Like