Xemu flatpak

Hello everyone,
I'm trying to use the Xemu flatpak but I'm experiencing an issue. The games won't go past the intro credits. After the intro game credits, the screen goes black and I'm kicked out of the OS and have to log back in. It's some type of permission issue. I placed the required files within the specified directory and i'm even trying to use Flatseal with no luck. What am I missing?
Screenshot from 2024-03-15 19-39-45

Is this with all games you've tried?

Also, what are the system specs of your setup? Just to get Halo 2 to run right, I have to crank all my settings to 11.

Yes, All games.
Specs Kernel: 6.5.0-25-generic x86_64 bits: 64 Desktop: GNOME 43.9 Distro: Zorin OS 17.1 Machine: Type: Laptop System: HP product: HP ProBook 445 G7 v: N/A serial: <superuser required> Mobo: HP model: 8730 v: KBC Version 13.26.00 serial: <superuser required> UEFI: HP v: S79 Ver. 01.08.00 date: 01/17/2022 Battery: ID-1: BAT0 charge: 32.0 Wh (98.8%) condition: 32.4/45.2 Wh (71.5%) CPU: Info: 6-core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 type: MCP cache: L2: 3 MiB Speed (MHz): avg: 1399 min/max: 1400/2375 cores: 1: 1400 2: 1400 3: 1400 4: 1400 5: 1397 6: 1397 Graphics: Device-1: AMD Renoir driver: amdgpu v: kernel Device-2: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD Integrated Webcam type: USB driver: uvcvideo Display: wayland server: X.Org v: with: Xwayland v: 22.1.1 compositor: gnome-shell driver: X: loaded: amdgpu,ati unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu resolution: 1920x1080~60Hz OpenGL: renderer: RENOIR (renoir LLVM 15.0.7 DRM 3.54 6.5.0-25-generic) v: 4.6 Mesa 23.2.1-1ubuntu3.1~22.04.2 Audio: Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A Device-3: AMD Family 17h HD Audio driver: snd_hda_intel Sound Server-1: ALSA v: k6.5.0-25-generic running: yes Sound Server-2: PulseAudio v: 15.99.1 running: yes Sound Server-3: PipeWire v: 0.3.48 running: yes Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 IF: enp1s0 state: down mac: b0:22:7a:ee:6c:95 Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi IF: wlp2s0 state: up mac: c0:3c:59:8f:e8:8c Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb Report: hciconfig ID: hci0 state: up address: C0:3C:59:8F:E8:90 bt-v: 3.0 Drives: Local Storage: total: 476.94 GiB used: 41.31 GiB (8.7%) ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 SDBPNTY-512G-1006 size: 476.94 GiB Partition: ID-1: / size: 467.89 GiB used: 41.3 GiB (8.8%) fs: ext4 dev: /dev/nvme0n1p2 ID-2: /boot/efi size: 511 MiB used: 6.1 MiB (1.2%) fs: vfat dev: /dev/nvme0n1p1 Swap: ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swapfile Sensors: System Temperatures: cpu: 31.0 C mobo: 0.0 C gpu: amdgpu temp: 30.0 C Fan Speeds (RPM): N/A Info: Processes: 294 Uptime: 4m Memory: 15.02 GiB used: 1.36 GiB (9.0%) Shell: Bash inxi: 3.3.13 text

Additional settings:

I see from your output you're using Wayland - have you tried with X? I have much better results with X vs Wayland; all around. I don't have an AMD GPU but, do you have any control center settings or a way to change the performance of the graphics?

From what do you know that?

1 Like

I have tried X11 with the same result. No other drivers available except open source drivers according to the driver manager.

Upon further testing, xemu works if the PPA version is used. Unfortunately, PPA is only available on Ubuntu based systems.

Zorin OS is an Ubuntu based system.

1 Like

Strange.. But, if that works - it works! :+1: