Xerox VersaLink C405

Zorin 16 Pro / HP Notebook - 15-ay043ca (Touch) / VersaLink C405

Printer is autodetected but I cannot print to it. Printing a test page results in multiple dings from the printer, Zorin reports Printing completed. This happens for both LiveCD and installed instances.

Latest PopOS and Linux Mint live CDs detect the printer and print correctly (I include this to note that it is not a hardware or connectivity issue).

Any ideas?

Are you logging into Wayland? (Please check)

Can you post the output of:

lsmod | grep usb

I have found from doing a websearch that there are linux drivers for that printer here:

Sorry, I should have specified... The printer is network attached via Ethernet. No print server involved.

I have now ruled out the PC as the issue - I get the same results using a Lenovo desktop. I have now tried both CORE and PRO versions, same result.

Posting as requested but printer is Ethernet attached.

zorin@zorin:~$ lsmod | grep usb
usb_storage 73728 2 uas
usbhid 57344 1 hid_logitech_dj
hid 135168 4 usbhid,hid_generic,hid_logitech_dj,hid_logitech_hidpp

Yes, I found and installed that software. No joy. If anything, it's worse. At least with the built-in CUPS support the printer responds.

For your ethernet connected printer, does the solution worked out here help you any?

I apologize for my vague pointing elsewhere. This is not something I have much experience in myself. I hope I can at least rattle the handle or help point you in the right direction.

Thanks for your efforts.

As it turns out, the printing problem only occurs when sending a test page to the printer from the printer setup dialog. It's a replicable error from both CORE and PRO on multiple computers. However, when I print from an application, the job prints!

Because this works out-of-the-box on PopOS! and Linux Mint, I'm going to assume Zorin has some extraneous data being sent with the test page.

When printing the test page, the error code shown in the job log is 017-734. Xerox's website says:

Fault Code 017-734: IPP Data Error
Product support for: VersaLink C500_C600 Family, VersaLink C500, VersaLink C600

Article Id: 2106127.html | Published: 10/17/2019

Syntax error, usage of undefined command, parameter error, damage of the file, or internal error of the decomposer has occurred during the decomposer process of a direct print job that used IPP in its network protocol.

  1. Try Printing a Different Print Job to See if the Same Error Occurs. Take Action Depending on the Result.

  2. For Apple OS, Use a Different Print Method (Print Driver or Utility) Not Internet Printing Protocol to Print to the Device.

  3. Re-install Drivers on a Computer With Windows 8.8.1 or 10 for a Network Connection.

This is interesting since they both use CUPS, same as Zorin OS.

Is your firewall enabled?