Xfce-panel icons can't change when change the icon of an app

I don't know why the icons of xfce-panel, i mean icon for nemo or thunar or any app, when i change the icon of the app, that not effect on the icon on xfce panel(taskbar), it's only effect on desktop and taskmenu.

It will change the icon for the panel as long as you change the icon in the 16x16 size directory as well as the 24x24, 32x32, 48x48 and so on.
As I make Icon sets, I can confirm this.

1 Like

sorry , what do u mean with directory, do u mean the directory of the default theme of zorin lite? what if I use a custom theme, i go to it's directory and search for that folders?

Yes. Did you change the icon by changing the icon .png or .svg file?

Or did you install and use a Custom made Icon theme?

no, I have downloaded (windows 11 icon theme) and there r a lot of icons in it i want to change it, i did that, but that not effect on xfce-panel, i have changed the icon of nemo app,but that effect on desktop but not in xfce-panel(i still get the default icon the theme

Can you link to the theme?

I downloaded the We10X to examine, can you please post a screenshot showing your panel and a normal app icon?


that folder of the name files on the desktop(last one) is nemo, and the icon not matched with the one in taskbar(the first one after zorin icon)


I also use windows 10 theme

Ok, I had to download the We10X Special Dark, this time in order to compare them.

What youa re seeing is actually correct- if you look in /We10X-special/We10X-special-dark/apps/symbolic you will see the File-Manager-Symbolic icon that is being used by the panel. The symbolic icon does not match the regular icon.
According to the Icon Maker on their page, they said that this is intentional as that is how Windows 10 displays them.

This is also part of why I make my symbolic icons 100% match my regular icons...

1 Like



there r a lot of missing icon in the theme above that i'm using ,so I returned again to zorin-green dark theme and icon,I don't know but I noticed also in zorin-theme some apps not matched when using docklike taskbar, and matched when using window button as a pictures show above. I get gear icon in panel for ventoy app and panel perference window, and get strange icon for 4kvideodownloader app in the case of docklike, I think it is the problem of docklike, I think that may make effect after reinstalling docklike, Is there command to reinstall the docklike?

I have tried docklook alternative: dockbarx, it's working good with icon of apps

GitHub - M7S/dockbarx