XRDP blue screen

I have spent the last 2 days trying to get xrdp to work. I feel like I have tried every “fix” I found through google and nothing works.

I have installed Zorin OS 15.2 Lite + xrdp on a VM.
When connecting from Windows (RDP) I get the xrdp login screen, I enter my credentials and then nothing happens. It just hangs at the blue screen and eventually I get the “connection problem, giving up… some problem” message.

Any help is highly appreciated.

Hi, and welcome! Which VM software are you using? VB or VMWare?

Thanks for trying to help. I’m using VMWare.
As a side note: I have created another VM just to try xrdp on other distros and it seems to work on linux mint after fixing the xfce single session problem by adding the following to /etc/xrdp/startwm.sh

unset DBUS_SESSION_BUS_ADDRESS
unset XDG_RUNTIME_DIR
. $HOME/.profile

The same fix as well as all other suggestions I have found did not help on Zorin.

So you managed to work it on Mint xfce - what kernel version out of curiosity? Just wondering if that was the issue?

Also just found this - would be curious to know if you installed LXDE to your Zorin Lite and login to that environment:

I just downloaded the latest version of Linux Mint today (version 20) and installed it. Kernel version seems to be: 5.4.0-48-generic

As for your suggestion I already have the latest xrdp and xfce. This is what I get when I try to install it:
xfce4 is already the newest version (4.12.4).
xrdp is already the newest version (0.9.5-2).

I have also installed and logged into LXDE in console. However, I don’t know how xrdp chooses which environment to use (I have now: xfce, cinnamon, LXDE, Zorin OS Lite Deskop, and Openbox)

You need to choose the DE at login by clicking on the ‘cog’/‘gear’ and selecting LXDE before logging in. :wink: Once in follow that guides instructions … fingers crossed!

That works in console and I can use any of the installed DEs. They all work. However, RDP does not give me the choice to select the DE. So, I guess xrdp uses xfce by default and that gives me the blue screen and it just hangs until something times out and I get the “…giving up. Some problem.” message.

Can someone here please confirm using a virtual machine whether xrdp works on Zorin OS Lite?

Have you read this guide?
Maybe it’s solution will help.

2 Likes

Thank you, Aravisian! That worked!

1 Like