Yakuake F12 global shortcut not working

Hello!

I'm trying to get yakuake working on the default GNOME desktop. There's one similar post on this forum already, but that person was using Wayland, and also got an error message whereas I haven't seen any: yakuake seems perfectly fine with letting me set up F12 as the global shortcut to open it, but it simply doesn't work.

I've tried both the Flathub and ZorinOS installs, and even tried a different one called QTerminal. ZorinOS just doesn't seem to want to allow programs to set up global shortcuts. Is there a way around this? (side note: what's the actual difference between those installs? is it just a mirror or does ZorinOS imply that it's a version of the app specifically made to work on Zorin?)

Check Gnomes shortcut, it may be taken by something else.

Other than that, try Tilda instead it's Gnomes/GTK version of Yakuake which fits more nicely.

I linked that other post because I already followed the steps given. In other words, I checked, F12 is not currently a shortcut, at least not anywhere that I see.
Tilda looks nice but it's not working either. Shortcut only does anything if I am in a focused window of the software, which means it will only close, not open.