Z17 grub menu no longer shows windows 10 on other disk

I installed Zorin OS 17 on my computer. I changed grub settings in /etc/default/grub with no avail. When I run update-grub I get this,

Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/zorin/theme.txt
Found linux image: /boot/vmlinuz-6.5.0-15-generic
Found initrd image: /boot/initrd.img-6.5.0-15-generic
Found linux image: /boot/vmlinuz-6.2.0-39-generic
Found initrd image: /boot/initrd.img-6.2.0-39-generic
Memtest86+ needs a 16-bit boot, that is not available on EFI, exiting
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
done

This is my /etc/default/grub file after some attempts to fix the problem...

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="splash"
GRUB_CMDLINE_LINUX=""

GRUB_DISABLE_OS_PROBER=false
# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_THEME=/usr/share/grub/themes/zorin/theme.txt

Grub will show me Zorin OS along with other settings before booting after 5 seconds. I changed boot order in the BIOS to check if windows 10 is still bootable. (it is)

I mounted the windows 10 drive too before I ran sudo os-probe and I still get nothing.

You can comment that line with a hashtag
#GRUB_DISABLE_OS_PROBER=false
then tap ctl+o to overwrite, enter to save current configuration, ctl+x to exit the editor and run sudo update-grub.
I assume you added this line due to not seeing Windows at boot?

1 Like

Same thing happened to me but the solution provided worked so give that a try. I can see all my other operating systems since making the changes.

I'm sorry but I added that line, you are correct.

GRUB_DISABLE_OS_PROBER=false

I was trying to run sudo os-prober manually to see if that was the issue.

I just installed ZorinOS 17 on my previously dual-booted laptop and I am having the same issue. Windows 10 is reachable if I change the boot order in the BIOS.

After updating the grub menu again with sudo update-grub, the issue persists.

I did have to run this command to install grub though...

sudo grub-install /dev/sda

I don't know if that was something I wasn't supposed to do.