Zebra printer stopped communicating with Zorin OS

My Zebra Printer just quite printing. It is capable of printing not physically broke. I guess it has something to do with CUPS.

I am having to print shipping labels on 8.5 x 11 using my Cannon. The Zebra people said if I had Zoom or TeamViewer they would like to look and see if they could fix it. I had Team Viewer for more than 12 years not any more as of today I think I have Zoom.
How can I tell if I have: error: attempt to read or write outside of disk 'hd0'.

Are you seeing this error or asking how to tell if you have that error without having seen it?

Asking if I hah the problem since one of Zebra printer people got it to print a page.

It is unlikely. That generally is a Grub error.

They were able to get it to work, but not solve the issue?

1 Like

I called Zebra and they were scared trying to get involved getting Zebra printer installed on Zorin. They have no clue anything about Linux.

Here is what was done today: Zebra factory Tech showed me that the Zebra printer would print a test document. I could not get it to print a label but the green light blinked 4 times, so it is receiving information from XPSShipper.com app, I booted up in Windows 10 & installed Zebra in Windows and it printed out a shipping label. Since it prints in Windows means it is the CUPS driver since windows does't use CUPS to me means something in CUPS needs to be filled in or not linked.

This is as far as my knowledge goes. This has got to be some simple blank not filled in or filled in wrong.

Would someone with Zebra knowledge Please shine a little of that light this way. It had been working for a long time then quite.

What is your terminal output for

apt policy cups

Don't understand what you are asking.

You can open a terminal with the keyboard shortcut ctrl+alt+t or from the App Menu.
In the open terminal, please paste the command:

apt policy cups

Copy and paste the output here.

ezorb@ezorb-AX370-Gaming-5:~$ apt policy cups
Installed: 2.3.1-9ubuntu1.2
Candidate: 2.3.1-9ubuntu1.2
Version table:
*** 2.3.1-9ubuntu1.2 500
500 Index of /ubuntu focal-updates/main amd64 Packages
500 Index of /ubuntu focal-security/main amd64 Packages
100 /var/lib/dpkg/status
2.3.1-9ubuntu1 500
500 Index of /ubuntu focal/main amd64 Packages

Would not paste up above, I also could not copy & paste I had to type it in for some reason.

We have a few hints here that point in different directions.
Your printer was working and then stopped - perhaps after an Update (Upgrade). And it is known that the Zebra Printer works on the earlier version of CUPS, according to Zebra.
It is possible that downgrading CUPS to the previous version may resolve your issue. If it does, you can use apt-mark hold on the package to prevent it being upgraded.
That the Zebra Tech rep was able to print a test page casts some doubt onto that.
He did something that worked - and that worked on the latest CUPs available version.
If we can delve into what he did... we may have more luck finding the solution - for example if some other upgrade is interfering with CUPs.

I found this in one of Zebra emails, We have tested the printer by printing a configuration label and we have confirmed that the printer is working fine with solid green light on it. Let us know should you have any concerns in installing the driver for your Linux computer.
In the above he wasn't using XPS Ship software.
What/how can we move my CUPS back? or prove the upgrade is not part of picture causing problems.

Was this performed by a remote connection to the printer? OR a remote connection to Your Computer, operating the printer/

Zebra Tech was in Asia, a remote connection to Your Computer, operating the printer/ I was on phone with him.

So, he connected remotely to your computer on Zorin OS?
Any idea what steps he took?

1 Like

I will ask him the steps he took.

1 Like

I wonder if the Zebra printer will run on the Grub version or Zorin16 Pro?

All Zebra Printers Support Ubuntu / Zorin, You Should take a look at this :thinking:

Above my pay grade. Are you saying switch back to Zorin 16 Pro and it will/should work? I now don't remember why I had to switch from Zorin16 Pro
to Zorin Lite.

It looks like Zebra is ignoring me. I don't guess we will get an answer. What is your thought on switching back I now don't remember why I had to switch from Zorin16 Pro to Zorin Lite.

They are Just names, in fact we can consider Lite Version(Xfce) better than Pro cause it is just Gnome with additional themes :man_shrugging:

Try to Reset the Printer.