Zenbook ux5304va has no sound from internal speakers

Hello,
I know that this topic is well know nown. I've read tones of answers on this topic and tried many solutions, without success. After several solutions tests, It even degrades my Zorin OS sound on earphones (delays in sound and videos) and I was forced to reinstall my Zorin OS.
Here a summary of my system:
Kernel: 6.5.0-21-generic
Linux version: ZORIN OS PRO (V17)
x86_64
PC: ASUS Zenbook Oled 13" (UX5304 VA)

I've installed HW probe on my Pc and got the probe details: https://linux-hardware.org/?id=pci:8086-51ca-1043-16d3
Can you please help me to find and fix/install the correct driver for the sound card to make it work on speakers? By the way the sound is working on earphones.
Thank you in advance.
Best R.
Eddy

Open bug reports on this same issue (Speakers not working; headphones are):
https://bugzilla.kernel.org/show_bug.cgi?id=216311

You might try a later kernel:

sudo add-apt-repository ppa:tuxinvader/jammy-mainline

sudo apt update && sudo apt install linux-generic-6.07

Welcome to the Forum!

Did You tried the PulseAudio Console to control if Your Speakers will work? If not open the Terminal and type sudo apt install pavucontrol, open it (You should find it in the Multimedia Category) and test if it will work.

Hello,
Thank you very much. Yes indeed, I installed pavucontrol and I played with the speaker. I see the sound meter working when I put a movie for example but no speaker sound.
Thanks

You mean I have to try these 2 commands by updating the Kernel? or I have other commands to do?

Those two commands will up the kernel.
Once those two are issued successfully, reboot to test the new kernel.