ZL16.2 Xfce + Whiskermenu: Super button problem

Yesterday I swapped the Zorin Lite menu for Whiskermenu. The Super button worked to bring up the menu until earlier today, when pressing it would do nothing.
I went to Keyboards > Application Shortcuts > Add, and made Super open usr/bin/xfce4-popup-whiskermenu. And now the Super button brings up the Menu, yay!... but Super+D won't show the desktop any more. :confused:
Clicking Reset to Defaults restored Super+D but Super alone stopped bringing up the Menu.
I've tried Adding a shortcut for Super=menu a couple of times now, and for some reason it keeps disabling Super+D for desktop. And resetting to defaults keeps disabling Super for menu.
Other Super combos still seem to work.
I'm not sure how to create a Show Desktop key combo from scratch.
Any ideas how to get both things working together?

1 Like

Does this help?

I'm afraid not. Show desktop was already listed there as Super+D. I edited it anyway, went through the action shortcut process, entered Super+D. And it still doesn't work. :confused:
EDIT: I just logged out and back in again, to see if that would affect things. No change, still nothing when I do Super+D.

In the meantime, I've added the Show Desktop plugin to the Panel. But Super+D is second nature to me (and was heavily used yesterday when I was working on Conky).

I suspect it might be the way Team Zorin tweaked xfce for the Zorin desktop. Just a guess.

Weird thing is, there was no problem for almost a day: both Super for Whiskermenu and Super+D to show desktop were working.
It stopped some point after working on something unrelated, Conky (which meant I was using Super+D all the time no problem, and Super for menu too.)